Go Down

Topic: Problem with Arduino UNO REV3 (Read 1 time) previous topic - next topic


Hi, I get an ARDUINO R3 Board... as I try to connect it to my laptop using the cable that cames with the board nothing happened, I mean, Win XP don't recognize it...so I used another USB cable, this time Win XP said it's an "ATMEGA16 U2 UDF", I said what's that... so browsing the arduino site I see that my arduino doesn't have any firmware on it, the board was empty!!!, anyway I downloaded the Arduino 1.0 IDE with all the drivers and files I need to run the enviroment... Ok I downloaded the FLIP utility from ATMEL and then I programmed the flash with the arduino uno serial-usb firmware, then I reconnect the board and my laptop recongnized it as an Arduino UNO R3... I installed the drivers that came with the IDE and I opened de IDE to program my first Proyect, The blink example, I see that was impossible to program IT and It was because the board doesn't have a bootloader, I made the parallel programer and I burned the bootloader, all OK, The IDE says that all is Ok and the bootloader was burned OK. here comes the problem... the bootloader is Ok, the Firmware is Ok, my ├▒laptop recongnizes the arduino and the cable semms to be fine but I can't burn trhe blink example, the led on pin 13 is always ON, it only blinks when I push the reset button... it seems the board can't send data or the laptop can't send or receive data... I've tried to burn the program blink with the parallel programer and Oh It writes the program to the ATMega very fine... but I saw the serial monitor and the data may be not OK, I don't know waht to do... I'll need to buy a new board... someone knows what's coming on with my arduino... thanks for reading. I need your help S.O.S... sorry for my english. I'm from Argentina.


Wow Fred... you have definitely gone the distance on this UNO.  First question, did you notify the vendor that your UNO was not bootloaded?  Sometimes they are accommodating to this issues and replace it (if you did not release the blue smoke from the chips...).

Second question, do you have access to a programmer (other than the parallel you made) of another Arduino?

And finally, when you send the sketch, is there any activity on the UNO Rx/Tx lights?

If the D13 light is not blinking after you burn the UNO bootloader to the Atmega, you did not successfully program it.  If you can find another Arduino, you can use Nick's programmer to help troubleshoot your broken Arduino.



Thanks spcomputing, the led on the pin 13 only blinks if I push the reset button after I program the bootloader "ATMEGA328.hex" on the chip... , and when the booloader is being programmed the led on pin 13 blinks very fast continously for about 30 seconds then the IDE says that all is ok and the bootloader has being programmed succesfully the led on pin 13 blinks a few times and then stops blinking and remains ON forever.... then when I try to program a sketch the led on pin 13 binks a few times then the rx led blinks 3 times and here comes the msg of avrdude notinsync, I don't have another programmer, I think I'm gonna call the seller tomorrow so they replace my board. It can be the USB drivers or the ARDUINO UNO REV 3 DRIVERS, all seems to be OK  when I program dthe Bootloader, could you enunumarate me the step by step , to config this ARDUINO, you know.. all the steps since I connect my EMPTY ARDUINO until I program the first sketch, thanks... I aprecciate that you've reply my question so fast... so what can I do?... perhaps with this info you'll know where is the problem...


Are you burning the bootloader through the Arduino IDE or AVRDUDE?  Also, you can try changing the programmer in the Arduino IDE to Parallel, select the Blink sketch and File -> Upload via Programmer to see if your Parallel programmer is working correctly.  This will wipe out the bootloader, so you will have to reload the bootloader afterwards.

You mentioned "Atmega328.hex" for your bootloader file, where are you getting your this file?  The Uno file is in \arduino-1.0.1\hardware\arduino\bootloaders\optiboot\optiboot_atmega.hex.


Dec 03, 2012, 02:14 am Last Edit: Dec 03, 2012, 02:19 am by fred1986 Reason: 1
I burned the bootlder through the arduino IDE->Burn Bootloader.. yes I try to program the blink sketch with the pareallel programer and the board Blinks OK so the bootloader seems to program OK, but for example when I ise the write function or the print function in the sketch the received data in the serial monitor is not ok, for example I print "hello world" and I receive other random characters seems the serial port comes crazy so the board receives the program by the paralel port but it seems that it doesn't send data correctly... oh and yes the bootloader is "optiboot_atmega328.hex" and I have the arduino 1.0.2 IDE... I downloaded from the oficcial web page... and in the "boards.txt" file in the section of "UNO" is selected that bootloader so the bootloader is OK... I made the parallel port again from zero and get the same error.


I would agree with your assessment that the Atmega328 looks OK.  Now, for the 16u2.

When you used FLIP, which firmware did you use?

Go Up