Pages: [1]   Go Down
Author Topic: Suddenly unable to load a sketch to Mega ADK, now may have stuffed up bootloader  (Read 335 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 21
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi all,

I've been having trouble recently with uploading a sketch to my Mega ADK using arduino 1.0.1 . I've been trying to fix it but now I think I may have stuffed up the boot loader. Here's the steps I've taken and things I've noticed

1) Everything thing is working fine, I have a custom sheild and an ethernet sheild attached to the board. 
2) A couple of weeks ago I started getting "verification errors. First mismatched byte at ..." popping up after uploading but , the sketch still uploaded. I had a quick search but didn't find much on what was causing it so, I left it be.
3) A couple of days ago, I suddenly wasn't able to upload anything. It just sits "uploading" for a long time. I saw an error message about the incorrect board being used but I had the right board selcted from the drop down menu. I noticed that the LED on D13 was flashing very quickly and the TX/RX lights weren't flashing at all. Also, I noticed a high pitch whining sound but, I think this is from a MOSFET that I stupidly put on pin 13.
4) I detached everything from my arduino, including the sheilds and tried again. I noticed that the LED was no longer flashing but was always on. The TX/RX LEDs weren't flashing but, every few seconds would flash very dimly and briefly. Still no success. When I plugged the USB cable in I notices the D13 would flash once.
5) I did a bit more research and based on the "wrong board" message and decided that I should reburn  my bootloader so, I followed the instructions here http://arduino.cc/en/Hacking/ParallelProgrammer?from=Main.ParallelProgrammer . I keep getting  an error while burning the bootloader
Quote
verification error, first mismatched at byte 0x3e000
0x0d != 0xff
verification error; content mismatch
I've got Parallel Programmer Selected as the programmer and "Mega 2560 or Mega ADK" selected as the board and I'm not sure which COM port to use (1 or 2) so I've tried both. I've also tried changing the serial.debug_rate  in preferences.txt but have had no success ( I just guessed some baud rates to use 9600, 115200, 19200).
Also, the LED on D13 no longer flashes when power is applied, its always on. This is why I think I may have stuffed the bootloader.

Does anyone have any ideas what I could be doing wrong, or have any suggestions for some other approaches?

Any help is greatly appreciated.


« Last Edit: December 04, 2012, 12:51:50 pm by alphabetSoup » Logged

Poole, Dorset, UK
Offline Offline
Edison Member
*
Karma: 50
Posts: 2221
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Just like you the first thing I'd try is uploading without the shields (that custom shield worries me) and see what happens.

Try blink.

I don't think you will get to up load as (high pitched noise eek) I think you need to get a new AtMega chip.

I think you should ask for help with the custom shield! (big time).

Mark
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 21
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi Mark,
I've been trying to upload Blink but haven't been able to. It was the first thing I tried once I started having trouble uploading.  

The high pitch whining wasn't produced after I took the sheilds off.

I'm really hoping I don't have to replace the chip so am willing to chase a few things up first

« Last Edit: December 05, 2012, 04:18:21 am by alphabetSoup » Logged

Pages: [1]   Go Up
Jump to: