Pages: [1]   Go Down
Author Topic: Problème, erreur, avec Arduno UNO  (Read 647 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 36
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour,

Je viens de me procurer une Arduino UNO. J'ai bien téléchargé l'IDE avec les Drivers (version 1.0.3)

Tout allait bien, j’écris 2/3 programmes, je test, j’améliore, je m’éclate ! Quand tout d'un coup, lorsque j’envoie mon prog vers l'Arduino ce message s'affiche: avrdude: stk500_getsync(): not in sync: resp=0x00

Ça compile et après ça m'envoie ce message. Ça le fait même pour mes programmes qui fonctionnaient avant...
Savez vous se qui se passe ? Et comment arranger ce problème ?

Merci Beaucoup !
« Last Edit: December 16, 2012, 01:59:04 pm by MrPoulet » Logged

france
Offline Offline
God Member
*****
Karma: 15
Posts: 877
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Vérifier d'abord le port COM et le baudrate.
Logged

Christian

Offline Offline
Newbie
*
Karma: 0
Posts: 36
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Merci pour la réponse rapide !

Je suis sur le bon port COM et mon baudrate est a 9600, j'ai essayé d'autre valeurs mais ca ne change rien...
Logged

Offline Offline
Faraday Member
**
Karma: 34
Posts: 5154
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Merci pour la réponse rapide !

Je suis sur le bon port COM et mon baudrate est a 9600, j'ai essayé d'autre valeurs mais ca ne change rien...

bonsoir
L'IDE tourne sous quel OS ? (windows,linux,)
Si windows le port com est toujours vu ?
un arret/redémarrage de l'ordinateur ne change rien ?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 36
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Sous windows 7- 64
Et un redémarrage n'a rien changé.
Mon port COM est bien visible.

Et quand j'essaie d'envoyer mon programme la led orange de l'arduno clignote rapidement, donc la liaison est bien faite.
Logged

France
Offline Offline
Faraday Member
**
Karma: 55
Posts: 5347
Arduino Hacker
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour,

Le dernier programme utilisait le port série ?
Ou utilisait il les broches 0 et 1 ?

Si oui il existe une méthode qui consiste à garder le bouton reset appuyé tout en lançant l'upload, puis à le relacher au moment où l'ide affiche la taille du programme.
Logged

Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

Offline Offline
Newbie
*
Karma: 0
Posts: 36
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Effectivement j'ai utilisé les sorties de 0 a 9 sur mon dernier prog. Il ne faut pas utiliser la 0 et la 1?

J'ai essayé la technique du reset mais ça affiche toujours le même message... arf
Logged

France
Offline Offline
Faraday Member
**
Karma: 55
Posts: 5347
Arduino Hacker
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Effectivement j'ai utilisé les sorties de 0 a 9 sur mon dernier prog. Il ne faut pas utiliser la 0 et la 1?
Lit bien ce qu'il y a marqué sur les broches 0 et 1: "Tx Rx" = port série = port d'upload.
Règle n°1 en arduino: ne jamais utiliser les broches 0 et 1, sinon ... blocage.

J'ai essayé la technique du reset mais ça affiche toujours le même message... arf
Il faut faire plusieurs essais, tout est une question de timing.
Techniquement il faut faire en sorte que le moment où avrdude (le logiciel de programmation) ouvre le port série et le moment où le bootloader de l'arduino se lance (juste âpres le relâchement du bouton reset).
Logged

Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

Offline Offline
Newbie
*
Karma: 0
Posts: 36
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

OK Super merci beaucoup pour votre aide.

C'est effectivement a cause de cette pin 0 que j'avais relier a la masse.
Merci beaucoup de m'avoir sortie de la !

Bonne soirée! Cordialement Mr Poulet ! smiley
Logged

Pages: [1]   Go Up
Jump to: