Go Down

Topic: Diecimila Program uploading problem (Read 687 times) previous topic - next topic


Hi guys

I've just started to use a Arduino Diecimila and tried to upload my first program. As soon as I hit the upload button, I get the message:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I've read on the Troubleshooting page that some Decimila were burned with the wrong bootloader.

Some of the Arduino Diecimila boards were accidently burned with the Arduino NG bootloader. It should work fine, but has a longer delay when the board is reset (because the NG doesn't have an automatic reset, so you have to time the uploads manually). You can recognize the NG bootloader because the LED on pin 13 will blink three times when you reset the board (as compared to once with the Diecimila bootloader). If your Diecimila has the NG bootloader on it, you may need to physically press the reset button on the board before uploading your sketch. You can burn the correct bootloader onto your Diecimila, see the bootloader page for details.

My LED on pin 13 does blink three times before I get the error message. I've also tried to reset my board in several ways as described in other threats. Nothing worked.

Does anyone know a possible solution to that problem?


Did you also change the board type?
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Go Up