Go Down

Topic: avrdude: stk500_getsync() (Read 1 time) previous topic - next topic

ger_94

Dec 05, 2012, 07:03 am Last Edit: Dec 05, 2012, 07:12 am by ger_94 Reason: 1
Hi! I bought an arduino UNO board and, when I connect it to the usb the led with an L aside blinks but when I try to run any example (like Blink) I get the error "avrdude: stk500_getsync(): not in sync: resp=0x00" and I tried everything I read from threads like this but nothing works. Programmer is set to AVRISP mkII but I tried changing it to other options and it didn't work, broad is set to Arduino UNO and Serial Port to COM1 (the one option I have), I trying reseting before uploading the code and after the message "binary sketch size..." and nothing...

I'd be very happy if someone could help me...

Thanks in advance.

andyr31

yep, i got same problem with my boarduino

dannable

Have you done the loop-back test to make sure everything is communicating properly?
Beginners guide to using the Seeedstudio SIM900 GPRS/GSM Shield

ger_94

#3
Dec 05, 2012, 04:58 pm Last Edit: Dec 05, 2012, 05:21 pm by ger_94 Reason: 1
Well, I did it now in my PC and notebook. When I did it in my PC my arduino didn't pass the test, but, when I did it in my notebook it passed the test. However, when I tried to run the blink code (in my notebook), it threw me the same error...

dannable

What I have done before to test it is open the Arduino software without the board connected, go to Tools/Serial port and make a note of what ports are there. Then when connect the board I get a new port appear and that is the one I select. Unfortunately I believe that this process doesn't always work, depending on the operating system, etc! But it does for me.

Com1 doesn't sound right, but there again it could be.
Beginners guide to using the Seeedstudio SIM900 GPRS/GSM Shield

ger_94


What I have done before to test it is open the Arduino software without the board connected, go to Tools/Serial port and make a note of what ports are there. Then when connect the board I get a new port appear and that is the one I select. Unfortunately I believe that this process doesn't always work, depending on the operating system, etc! But it does for me.

Com1 doesn't sound right, but there again it could be.


Why com1 doesn't sound right? should it be only COM? In my notebook the one option is COM3 =/

dannable

Well I'm still running XP and all my Arduino COM ports are double digit! But the very low numbered ones are/were for system peripherals I believe. As you can tell I'm no expert in this area, just know what works for me!
Beginners guide to using the Seeedstudio SIM900 GPRS/GSM Shield

Nick Gammon


... broad is set to Arduino UNO and Serial Port to COM1 (the one option I have) ...


That suggests to me that the USB driver is not installed. There are some threads around about doing that. Have you read the troubleshooting guide?

http://www.arduino.cc/en/Guide/Troubleshooting#upload
Please post technical questions on the forum, not by personal message. Thanks!

More info:
http://www.gammon.com.au/electronics

ger_94



... broad is set to Arduino UNO and Serial Port to COM1 (the one option I have) ...


That suggests to me that the USB driver is not installed. There are some threads around about doing that. Have you read the troubleshooting guide?

http://www.arduino.cc/en/Guide/Troubleshooting#upload


Thank you very very much for give me that link, it solved my problem, I have Win7 x64 bit so I installed the drivers 'manually' and a new option in serial port (COM3) appeared, now it seems to work fine!

Go Up