Go Down

Topic: CuHead WifiShield v2.0 Not working! (Read 2 times) previous topic - next topic

retsam4u


:~

Hi,

I'm new to the world of arduino so please be patient with me. I've purchased the Arduino Duemilanove and the CuHead WifiShield v2.0.

Although I have managed to get simple projects up and running on the Arduino and pulling my hair out with trying to get the WifiShield to work.

I tried the SimpleServer example.

I assigned the WifiShield a unique IP address and I reserved this IP on my router for the WifiShield.
I entered the IP address of my router, the SSID and password of my wifi and set the structure to INFRA.

Uploaded the code to the Arduino and although the RED Led on the WifiShield is on and steady, I can't ping it or access it via my browser.

What am I doing wrong?  :~

Any help will be much appreciated.

Thanks

Hal


Hi,

Did you managed to make your CuHead WifiShield v2.0 work? I'm having the same problem like you (I have Arduino Uno R3 and Linksys Wireless-G Broadband Router model WRT54GL). I've tried several libraries, sketches, router configurations, power sources but without luck. I even disabled DHCP on router but still didn't work.

From time to time my WifiShield connects to router (the red led lights up) but when going on router admin page to devices list I see the shield with mac and signal but without IP address assigned!

Please, if you have successfully connected your WifiShield to your wireless network and managed to run the WebServer example, please share your knowledge with us.

Thank you!

retsam4u

In the end I have connected the shield to my network (with my router). It seams that the router configuration doesn't have such much efect.
This is what i've done to make it work:
1. download library from AsyncLabs - version with user contrib. (https://github.com/asynclabs/WiShield_user_contrib)
2. changed it to work with arduino >= 1.0.0 (http://www.sundh.com/blog/2012/02/make-wishield-work-in-latest-arduino-ide/)
3. change for CuHead WiShield V2.0 => "using digital pin 8 for interrupt, changed setting in spi.h" (http://www.linksprite.com/forum/index.php?topic=155.msg634#msg634)

Router settings: (model: Linksys WRT54GL with Tomato firmware)
- router ip = 192.168.1.1; subnet mask = 255.255.255.0 (arduino wifi shield ip = 192.168.1.123)
- DHCP Server = enabled ; IP Range = 192.168.1.100 - 192.168.1.149
- B/G Mode = Mixed
- Broadcast SSID = enabled
- Channel = 2 - 2.417 GHz
- Security = WPA / WPA2 Personal ; Encryption = TKIP / AES
- Added wifi mac on Static DHCP table with IP = 192.168.1.123 and a Hostname = Arduino

Advanced router settings:
- DHCP / DNS : "Use Internal Caching DNS Forwarder" and "Intercept DNS Port (UDP 53)" options enabled

Arduino IDE version used: arduino-1.0.4


Go Up