Pages: [1]   Go Down
Author Topic: Clas Ohlson sockets, 433Mhz, Home Easy - all switched ON when just 1 wanted  (Read 1263 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 17
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi! I've question about Home Easy sockets. Problem is that when I trye to set ON to socket A, then all other 2 sockets B and C will switch also ON. Why..?

I bought 3 sockets from ClasOhlson (white set with three socket, PER-1500). First I read codes of my remote (it has 3 buttons ON, 3 buttons OFF and one ALL OFF) by using code from  Barnaby Gray 12/2008 and Peter Mead  09/2009, it worked fine I think as I got results like

sender 7439138
no group
on
recipient 0

sender 7439138
no group
on
recipient 1

... and so on. Then I tried this with sample code which has functions like  transmit(int blnOn, int txPin), void sendPair(boolean b), void sendBit(boolean b, int txPin), void setHEDevice(int integer), void itob(unsigned long integer, int length), like here
http://arduino.cc/playground/Code/HomeEasy

pinMode(txPin, OUTPUT);
Serial.begin(9600);
delay(100); // not sure if this needed
Serial.println("Setup starting..");
HomeEasy homeEasy;
homeEasy = HomeEasy();
homeEasy.registerAdvancedProtocolHandler(processReceivedRemote);
homeEasy.init();
// this should switch first socket ON?
setHEDevice(0); //Set destination home easy device (first device, 0)
itob(7439138,0); //Sender code from remote control - changed this to match mine
transmit(1,6);
delay(10);
transmit(1,6);

// this should switch just second socket ON? not all?
setHEDevice(1); //Set destination home easy device (first device, 0)
itob(7439138,0); //Sender code from remote control - changed this to match mine
transmit(1,6);
delay(10);
transmit(1,6);

I am just begun to program Arduino, so I wonder if this is caused by some bad programming...
Also question, how to generate extra remote control codes without having remote control?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 17
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Just information, everything works fine with this  smiley
https://github.com/erix/NexaTransmitter

I'm doing arduino mega to have web interface, and also feeding to cosm (works ok), and maybe same time 2.4ghz connections (at least receiving) fromm other arduinos (not yet tried same time when there is 5100 network, 433mhz module and temperature sensors, hopefully not any conflicts)
Logged

Pages: [1]   Go Up
Jump to: