Pages: [1]   Go Down
Author Topic: Arduino Leonardo and serial device under linux  (Read 540 times)
0 Members and 1 Guest are viewing this topic.
Germany
Offline Offline
Newbie
*
Karma: 0
Posts: 10
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

my Arduino Leonardo is always recognized as mouse and not as serial device on my Debian Lenny installation.

Here's the dmesg output:

[18358405.628660] usb 1-1.3.2.3.3: new full speed USB device using uhci_hcd and address 22
[18358405.781635] usb 1-1.3.2.3.3: New USB device found, idVendor=2341, idProduct=0036
[18358405.781660] usb 1-1.3.2.3.3: New USB device strings: Mfr=2, Product=1, SerialNumber=0
[18358405.781676] usb 1-1.3.2.3.3: Product: Arduino Leonardo
[18358405.781688] usb 1-1.3.2.3.3: Manufacturer: Arduino LLC
[18358405.782218] usb 1-1.3.2.3.3: configuration #1 chosen from 1 choice
[18358405.785073] cdc_acm 1-1.3.2.3.3:1.0: ttyACM1: USB ACM device
[18358413.476628] usb 1-1.3.2.3.3: USB disconnect, address 22
[18358413.696592] usb 1-1.3.2.3.3: new full speed USB device using uhci_hcd and address 23
[18358413.829544] usb 1-1.3.2.3.3: New USB device found, idVendor=2341, idProduct=8036
[18358413.829568] usb 1-1.3.2.3.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[18358413.829582] usb 1-1.3.2.3.3: Product: Arduino Leonardo
[18358413.829595] usb 1-1.3.2.3.3: Manufacturer: Arduino LLC
[18358413.830166] usb 1-1.3.2.3.3: configuration #1 chosen from 1 choice
[18358413.840275] input: Arduino LLC Arduino Leonardo as /devices/pci0000:00/0000:00:07.2/usb1/1-1/1-1.3/1-1.3.2/1-1.3.2.3/1-1.3.2.3.3/1-1.3.2.3.3:1.2/input/input9
[18358413.972884] generic-usb 0003:2341:8036.0006: input,hidraw1: USB HID v1.01 Mouse [Arduino LLC Arduino Leonardo] on usb-0000:00:07.2-1.3.2.3.3/input2

A serial device is present, when the Arduino boatloader is running (for 8s), but the device disappears after the sketch is loaded. Then the Arduino is recognized as mouse.

I've no modem-manager running...

The sketch is running fine under Mac OS X.

How can I fix this issue?

Thanks,
Picknicker
Logged

Pages: [1]   Go Up
Jump to: