Go Down

Topic: question de noob pour reset... (Read 727 times) previous topic - next topic

laurentjeuxlille

Bonjour,

je debute (clignotage de leds, affichage de températures, etc...), et j'ai une question concernant le branchement de l'arduino au pc...

j'ai un prog dans mon arduino.

je change de prog, je refais un autre montage, et je dois brancher par usb mon ardu au pc.

Mais, quand je branche l'ardu, le prog precedent redemarre tout de suite. Mais les branchement sur la plaque d'essai ont changé.

D'où question, comment faire un reset avant de brancher l'ardu avec la nouvelle connection à la plaque d'essai ?

Merci


patg_

Je me suis posé la même question et j'ai fini par faire un sketch qui ne fait rien.
Quand j'en ai fini avec un montage, j'uploade mon sketch qui ne fait rien avant de faire le montage suivant.
Mes Arduineries: http://breizhmakers.over-blog.com/

laurentjeuxlille

J'ai fait pareil.... mais je pensais qu'il y avait une autre solution....

papybricol

Bonjour,

une autre solution, qui évite de charger spécialement un programme "qui fait rien", systématiquement mettre un arrêt (par attente d'un appui sur une touche connectée toujours sur la même pin), au début des setup de tous les  programmes, avant l'affectation des INPUT OUTPUT......
Profiter de cet arrêt lors de l'ancien prog pour charger le nouveau.
Quand la mise au point est finie, si cet arrêt est inutile, le supprimer
  Et pour les plus prudents :smiley-red:......, ne pas alimenter les capteurs,les actionneurs, avant l'upload du nouveau prog les concernant....?

Je ne l'ai pas toujours fait, loin de là, et avec des configs dans tous les sens, des capteurs alimentés, je n'ai pas eu de problèmes.
Toutefois la question est justifiée, et montre de la claivoyance, quand on débute sans expertise sur l'électronique des microprocesseurs.

C'est bien de vouloir prendre soin de ces petites bêtes  ;)


...ils embarquèrent la logique, coupèrent les cordons, alors, libérés de leurs chaînes, une immensité s'ouvrait devant eux...

fdufnews

Quote
J'ai fait pareil.... mais je pensais qu'il y avait une autre solution....

En toute rigueur il faudrait faire:
Décâbler le premier montage
Reprogrammer l'arduino avec le nouveau programme (ce qui évite de programmer avec un soft qui fait rien)
Faire le nouveau montage

Mais bon comme le dit papybricol entre ce que l'on dit et ce que l'on fait.....

laurentjeuxlille

Bon, pour le moment, le prog qui ne fait rien me va...

Go Up