Pages: [1]   Go Down
Author Topic: Pro Mini R5 in love with its adapter -- SOLVED: watch your power feed  (Read 518 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hello all

first time I write here, sorry but this time it took days of googling and frustration and I didn't make it anyway :)

I got myself a bunch of Pro Minis 5V/16 (R5) and a "USB2serial Light" adapter for stuffing them.
Got some problems understanding why the Tools/Board/Right-type doesn't work, however the simple "Mini with 328" gets the job done. Code uploaded, works like a charm.
BTW, the purpose is to broadcast packets via an RF12B module.
The receiving station (a UNO R3) says everything's fine, packets are coming as intended.

And here lies the rub. Once I disconnect the USB2Serial and feed the Pro Mini with an external stabilized 5V (same pin I use to feed it from the USB2Serial), BAM, goes flatline. The LED is on, but nobody's home.
Removing TX/RX wires, the 100nF cap (reset pin) didn't help.
Since I couldn't remember how the reset pin is wired, I also tried to pullup/pulldown it, to no avail. No action, just the LED staring at me (and I'm sure, laughing its anode off).
As soon as I unplug the external power and reconnect the USB2serial it starts broadcasting again, without the need to upload.
Before you ask: same behavior even with an adapted version of Blink.
I know it can't be, but it feels like the code is running on the USB2serial, not the Pro Mini, if you know what I mean.


I'm sure it's something trivial I missed, but can't find out what.
Hintses, anybody?

Thanks in advance,
/freeant

« Last Edit: December 08, 2012, 01:50:07 pm by freeant » Logged

0
Offline Offline
God Member
*****
Karma: 39
Posts: 988
Get Bitlash: http://bitlash.net
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for the good diagnostics and well-formed question.

I believe external power is supposed to go into the 'raw' input on a pro mini.  Have you tried that pin?  I would also check for a clean ground connection to the external power supply.

-br
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi billroy, thanks for the remarks and the prompt reply.

That might be, I never tried to feed it through the RAW pin, I thought it would work like a UNO, giving 5V on 5V just bypasses the internal regulator.
I'll raise the voltage of the ext stabilizer a couple Vs and see.

Thanks for now, I'll get back soon :)
/freeant
Logged

0
Offline Offline
God Member
*****
Karma: 39
Posts: 988
Get Bitlash: http://bitlash.net
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

That's a very low dropout regulator and you may find it works fine even around +5.

Best,

-br
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

BR,

you were right, the drop is just less than half a V.

However, problem solved. And I'd like to share, as it's nothing to do with the symptoms but the info might be useful.

I was using a Texas 7805 with a couple caps on the output (some el 470uF and a 100nF poly for the spikes) that were connected to the wrong pin on the breadboard, so they basically weren't. Sheet happens.
The oscilloscope told me what was going on on the feed. Looked like a horror movie. I guess the Mini freaked out.
Fixed the pin, back on track :)

But it wasn't in vain; the lesson I learned today is: the Arduino wants good food.

Thank you so much for the help, sorry for the fuss and the time I made you waste, there was no way whatsoever to get it from afar.

See you around BR!
/freeant
Logged

Pages: [1]   Go Up
Jump to: