Go Down

Topic: Leonardo as ISP for ATtiny85 (Read 2478 times) previous topic - next topic



I want to upload sketches to an Attiny85 using my Leonardo as ISP.

I followed the (updated) instructions from the MIT. (Using IDE 1.0.1)

So, i uploaded the "Arduino as ISP" Sketch and selected the right board (Attiny85) and Programmer (Arduino as ISP) in the IDE's menu.

Next step is to burn the bootloader, but this error is occuring for me:
avrdude: stk500_getsync(): not in sync: resp=0x00

(I don't have this problem uploading sketches to the Leonardo.)

I checked the wiring a couple times, so i assume it's some kind of software problem.

I just don't get whats the problem.

Can anyone help me?


Do you have Atmel Studio installed on your system?

I know there is a problem when using an external programmer to update the Arduino bootloader with systems that have Atmel studio installed - see http://startingelectronics.com/tutorials/arduino/arduino-uno-burning-bootloader-avr-studio/


Dec 09, 2012, 06:06 pm Last Edit: Dec 09, 2012, 09:49 pm by kduin Reason: 1

no, i don't have Atmel Studio installed.

What else could cause my problem?


Dec 10, 2012, 09:46 pm Last Edit: Dec 10, 2012, 09:53 pm by Rog2323 Reason: 1
Maybe this will help you diagnose the problem: http://forums.adafruit.com/viewtopic.php?f=21&t=32708
They say there: Hold the shift key down while you press the upload button and post the resulting diagnostic output.
See what the diagnostics say...

Then this thread talks about making the capacitor bigger:


Dec 10, 2012, 10:25 pm Last Edit: Dec 10, 2012, 10:56 pm by kduin Reason: 1

i tried that shift-thing, didn't show anything.
Then i enabled the "verbose output" while uploading, and that's the result:

Code: [Select]
C:\+ARDUINO\ArduinoIDE-1.0.1\hardware/tools/avr/bin/avrdude -CC:\+ARDUINO\ArduinoIDE-1.0.1\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -pattiny84 -cstk500v1 -P\\.\COM4 -b19200 -e -Uefuse:w:0xff:m -Uhfuse:w:0xdf:m -Ulfuse:w:0x62:m

avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\+ARDUINO\ArduinoIDE-1.0.1\hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : \\.\COM4
         Using Programmer              : stk500v1
         Overriding Baud Rate          : 19200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.

The Attiny is probably not the problem, i tried both Attiny85 and Attiny84.

Is it possible that the Leonardo doesn't work for this stuff because of it's internal USB controller?


I'm using a 10uF capacitor.

As you said, maybe a bigger one would help?

I tried with 3 more capacitors (in paralell), but it also doesn't work.

Strange: When i choose Leonardo and upload something, even with the 4 capacitors, the upload succeeds!


Dec 11, 2012, 09:59 pm Last Edit: Dec 11, 2012, 10:05 pm by skootles Reason: 1
The instructions you're following are for an Arduino Uno, not the Leonardo. On the Leonardo, the SCK, MISO, MOSI, and SS pins were remapped, and are no longer on pins D13-D10. You'll have to use the ICSP pins instead.

Try this tutorial:


I can't tell you if it works or not, I haven't gotten my hands on a Leonardo yet (hell, I might just pick one up tonight for the sake of it). Also, you should use the cores from the Arduino-Tiny project instead of the ones in that first tutorial: http://code.google.com/p/arduino-tiny/


@kduin: what windows are you on? I hope it is not xp, I just discovered some problems with it.

The output you posted shows that the ide uses -cstk500v1. It should use -carduino instead (a work around, needed on windows). See http://arduino.cc/forum/index.php/topic,108270.msg1014458.html#msg1014458 for how to do this.

Go Up