Go Down

Topic: programmare il 644 ... ma come???? (Read 27503 times) previous topic - next topic

leo72


forse qualche cavola di incompatibilità con gli aggiornamenti toolchain, mi pare che quelli li hai fatti in tempi più recenti...

Ho riguardato sul mio blog. L'articolo per aggiornare la toolchain l'ho scritto il 27/10/2012, il primo package per il 644/1284 l'ho messo online il 2/11/2012 quindi avevo già la toolchain aggiornata.

Michele Menniti

#91
Dec 19, 2012, 06:54 pm Last Edit: Dec 19, 2012, 06:57 pm by Michele Menniti Reason: 1
mi spiace, allora è proprio il momento di......
chiamare loro
:smiley-mr-green: :smiley-mr-green: :smiley-mr-green:
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

MauroTec

Primi segni di tempesta magnetica dovuta all'interpolatore sensoriale installato in cantina, ricordatevi non incrociate mai il flusso.
Incrociare il flusso è male. Ok
:D
Ciao.
AvrDudeQui front end per avrdude https://gitorious.org/avrdudequi/pages/Home

Michele Menniti


Primi segni di tempesta magnetica dovuta all'interpolatore sensoriale installato in cantina, ricordatevi non incrociate mai il flusso.
Incrociare il flusso è male. Ok
:D
Ciao.

appunto, quello che dicevo io: TX con TX e RX con RX :smiley-mr-green:
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

Paolo S

cavolo ... nessuna ipotesi di soluzione all'orizzonte!!!!  =( ... io ieri non ho potuto fare alcuna prova....

Ho visto che lo schetch arduino ISP utilizza  Serial.begin(19200)... mi chiedevo: può avere qualche rilevanza con la mancata comunicazione con il 644??

... intanto prendo atto della difficoltà di attivare il serial monitor quando sull'arduino programmatore cè lo schect arduinoISP .. ed è un problema serio perchè la visualizzazione su seriale mi è quasi indispensabile per fare il debug....

mi sa che mi conviene fare lo sviluppo della singola "implementazione" sul 328.. poi una volta resa funzionante traslo tutto sul 644 .....


Michele Menniti

Non ti preoccupare Paolo, ormai che Leo si è messo a fare le prove la soluzione la si trova, devi solo avere pazienza....

@ Leo: ovvio che la soluzione va trovata  :smiley-sweat: e che a questo punto conviene rifare qualche prova anche col 1284 e anche una prova con la 0022, ma non per contraddirti, semplicemente per capire se la direzione delle prove deve essere sw o hw, così siamo troppo al buio. Stanotte mi è venuto un flash, chissà se abbiamo a che fare con un problema di livelli... prova a mettere una R da 22k come pull-up sull'RX del 644; altra prova che puoi fare è eliminare la componente continua: metti in serie ai due segnali due C da 1µF. Ovvio che sono prove al buio, ma se avessimo un minimo di risposte positive si ci potrebbe lavorare su.... Se ti fermi comincio io, a questo punto non possiamo pensare che questa bestiola non sia programmabile/utilizzabile via seriale, peraltro io dispongo di svariati Convertitori: FT232RL, MCP2200, CP2100, oltre a tre Arduini, in più ho la strumentazione che potrebbe darmi una mano, e siccome ormai sono al countdown delle mie sospiratissime vacanze, penso proprio che aggiungerò anche questi test all'elenco :smiley-sweat: non possiamo deludere Paolo XD
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

leo72


cavolo ... nessuna ipotesi di soluzione all'orizzonte!!!!  =( ... io ieri non ho potuto fare alcuna prova....

Ho visto che lo schetch arduino ISP utilizza  Serial.begin(19200)... mi chiedevo: può avere qualche rilevanza con la mancata comunicazione con il 644??

Non c'entra. Per comunicare via seriale il chip Atmega328 va tolto. La comunicazione si instaura fra Atmega8U2 e Atmega644: la scheda Arduino in questo caso diventa come il tuo convertitore USB/seriale.

Quote

... intanto prendo atto della difficoltà di attivare il serial monitor quando sull'arduino programmatore cè lo schect arduinoISP .. ed è un problema serio perchè la visualizzazione su seriale mi è quasi indispensabile per fare il debug....

Anche questo forse è un falso problema perché se tieni montato il 328 sull'Arduino mentre tenti di comunicare con l'Atmega644 via seriale è normale che non possa funzionare nulla dato che il 328 sull'Arduino instaura lui la comunicazione con l'Atmega8U2.

leo72


@ Leo: ovvio che la soluzione va trovata  :smiley-sweat: e che a questo punto conviene rifare qualche prova anche col 1284 e anche una prova con la 0022, ma non per contraddirti, semplicemente per capire se la direzione delle prove deve essere sw o hw, così siamo troppo al buio.

Difatti dei test li farò.
Però quando ho pubblicato il package per 644/1284 ero già con la 1.0.1, e ti ricordo che i test erano stati tutti positivi.

Quote

Stanotte mi è venuto un flash, chissà se abbiamo a che fare con un problema di livelli... prova a mettere una R da 22k come pull-up sull'RX del 644;

Ma così non si crea un partitore con le R da 1K che sono presenti sull'Arduino?

Quote

altra prova che puoi fare è eliminare la componente continua: metti in serie ai due segnali due C da 1µF. Ovvio che sono prove al buio, ma se avessimo un minimo di risposte positive si ci potrebbe lavorare su.... Se ti fermi comincio io, a questo punto non possiamo pensare che questa bestiola non sia programmabile/utilizzabile via seriale, peraltro io dispongo di svariati Convertitori: FT232RL, MCP2200, CP2100, oltre a tre Arduini, in più ho la strumentazione che potrebbe darmi una mano, e siccome ormai sono al countdown delle mie sospiratissime vacanze, penso proprio che aggiungerò anche questi test all'elenco :smiley-sweat: non possiamo deludere Paolo XD

Fermare non mi fermo ma non ti dico neanche di stare fermo perché avendo appunto la strumentazione giusta puoi capire meglio di me perché la comunicazione seriale, una volta che è partita, si interrompe casualmente in corso d'opera.

Michele Menniti

sì che il partitore si crea ma così comunque dovremmo dare un "contributo in continua", mentre nel caso dei C facciamo la cosa opposta; posso farele io queste prove tra qualche giorno, se preferisci.
Sulla 0022 insisto solo perché serve conferma che il problema sia hw o sw, non perché non ti credo :smiley-sweat: :smiley-sweat:.
Per capirci ti rcconto una cosa che mi è successa una ventina di gg fa: testo un circuito che prevede un partitore d'ingresso, ad un certo punto trovo una buona combinazione in termini di risultati e mi faccio convinto che il partitore di ingresso non serve più, lo elimino ed infatti il circuito continua a funzionare ed anzi va meglio di "un qualcosa". Tutto felice spengo, torno al lab dopo tre giorni, senza aver smontato nulla, ripeto il test, una schifezza! rimetto il partitore come prima prova, tutto ok; ora ti risparmio la scoperta del motivo ma è solo per dire che a volte si creano concomitanze tali per le quali una cosa funzioni regolarmente e poi al venire meno di una qualsiasi variabile le cose peggiorano anche drasticamente, d'altra parte lo stai verificando da solo, quindi o ti sta sfuggendo qualcosa di macroscopico oppure i test fatti alcuni mesi fa avevano delle circostanze che in questo momento non sono ripetute.
Io ho conservato la mia installazione 0022, in "parallelo" alla 1.0.1, a questo punto posso farla io anche questa prova, ma prima devo finire assolutamente il lavoro che sai e poi devo dedicare del tempo ai test di un display che mi dovrebbe arrivare a momenti, l'ho promesso ad un amico del Forum, quindi posso solo rimandare il mio progetto personale di questo momento, tanto sono a buon punto.
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

leo72

Ci sono riuscito  ]:D
Ho ricontrollato tutti i collegamenti e questa volta avevo sbagliato i collegamenti dei C del quarzo da 16 MHz. Girando la basetta non pensavo al fatto che le linee laterali blu e rossa avevano cambiato posizione e ieri sera, collegandole con poca luce, avevo invertito i collegamenti. Però, siccome sulla basetta ho altre cose, la linea positiva non è collegata a nulla e quindi semplicemente i C non erano né a massa né a Vcc.

Inoltre il mitico suggerimento di Michele è da top10  ;)
Ho messo una R di pull-up da 10K sulla linea RX e tutto ha funzionato al primo colpo. Non ho usato i C in serie verso massa per eliminare i disturbi in alternata.

@Michele:
Ora, però, Michele DEVI usare il suo DSO e vedere i livelli di quei segnali e capire come siamo messi lì sopra.

leo72

#100
Dec 20, 2012, 10:03 am Last Edit: Dec 20, 2012, 10:10 am by leo72 Reason: 1
E' INCREDIBILE!
Ora mi dice nuovamente "programmer is not responding"....  =(

EDIT:
smuovendo l'Arduino a volte programma a volte no.
Ora vabbé che domani c'è la fine del mondo per cui potrebbe darsi che le leggi della fisica stanno saltando  :smiley-yell:, ma questa cosa ha il sapore dello sciamanesimo  :smiley-sweat:
Mi sa che i pin della mia Arduino siano un po'.... spanati (non so se è italiano).

Michele Menniti

Leo, è un problema certamente di contatti sommato ad una eccessiva sensibilità del 644, è assolutamente necessario che li ripeta anch'io; tu hai usato anche la Luigino che non dovrebbe essere altrettanto spanata, magari alla luce di queste nuove prove chissà....
Quella storia dei Maya è una delle più grandi palle raccontate all'umanità, il 22 saremo ancora qui a festeggiare il 644 che funziona ;)
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

leo72


Leo, è un problema certamente di contatti sommato ad una eccessiva sensibilità del 644, è assolutamente necessario che li ripeta anch'io; tu hai usato anche la Luigino che non dovrebbe essere altrettanto spanata, magari alla luce di queste nuove prove chissà....

Sicuramente.
Ah, per dovere di cronaca. Con la pull-up da 10K anche sulla linea TX il caricamento va a buon fine sempre. Alcuni problemi che avevo menzionato, e cioè che il caricamento dava errori eppure pareva fosse stato portato a termine perché lo sketch partiva, erano dati dal fatto che in fase di verifica i dati non erano stati spediti correttamente verso il PC.

Per cui, riassumo i miei test:
1) R di pull-up da 10K (per 5V) sulle linee RX e TX: tutto OK
2) aggiunta del C da 0.1uF poliestere in serie alle linee RX e TX: ERRORE. Sembra dargli noia, non so il perché.
3) aggiunta di un C da 100pF ceramico in serie alle linee RX: tutto OK. Anzi, PERFETTO. Programmo al primo colpo.
4) aggiunta di un C da 100pF ceramico in serie alle linee RX e TX: ERRORE. Non programma il micro.

Quindi la combinazione vincente per me è:
R di pull-up da 10K su RX e TX, C in serie da 100 pF su RX

Quote

Quella storia dei Maya è una delle più grandi palle raccontate all'umanità, il 22 saremo ancora qui a festeggiare il 644 che funziona ;)

Non vedo l'ora che sia domani per prendere per il cul... tutti quelli che ci credono. Siamo nel 21° secolo eppure la gente crede a 'ste ca@@ate più di quando l'umanità era nel medioevo!

leo72

Uh oh... ho brickato l'unico 1284 che avevo... merd....  :smiley-roll-sweat:
La signature a 0x535353 come la vedete?  :smiley-eek:

Michele Menniti

io la vedo tanto di Banda Bassotti quella signature però è stravagante e comunque il brickage :smiley-sweat: non c'entra nulla con la signature; quei tre byte mostrano il valore originale oppure 000000 o FFFFFF quando si cancella, certamente non esiste possibilità che venga "cambiato", riprova con calma, e comunque se hai brickato ti basta riportare i segnali dello schedino HV del 328 sulla bread e risolvi in dieci minuti; scaricati il mio articolo gratuitamente dal sito di El In, ci sono tutte le connessioni, non puoi sbagliare; ma prima ricontrolla bene, per me continuano ad essere problemi di contatti.

Da quello che dici sembrerebbe confermata l'ipotesi dei livelli, anche se è strano, però con le mie prossime prove e misure vedremo come stanno le cose; sarà importante ora che ripeta le prove Paolo e vediamo che ne esce. Sul valore dei condensatori ho sbagliato io, ragionavo sui termini di 10 e passa MHz, mentre qui siamo a frequenze molto più basse, quindi va benissimo il valore che hai usato! Io ora sono a pranzo con i colleghi per gli Auguri, ci sentiamo più tardi.

GRANDE LEO!!!!
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

Go Up