Go Down

Topic: programmare il 644 ... ma come???? (Read 25 times) previous topic - next topic

tonid

#210
Jan 20, 2013, 04:22 pm Last Edit: Jan 20, 2013, 04:23 pm by tonid Reason: 1
Ciao Leo,ho aggiunto il C da 100nF in parallelo alla pull-up ma devo comunque eliminare quello in serie al reset altrimenti non va.
La cosa strana è che a me funziona benissimo senza filtro RC e,se lo aggiungo,carica bene lo stesso...
Mi pare di ricordare che il problema lo avevate su entrambi i chip 644/1280,giusto?

leo72


Ciao Leo,ho aggiunto il C da 100nF in parallelo alla pull-up ma devo comunque eliminare quello in serie al reset altrimenti non va.

Te lo avevo detto anche io:
Quote
il C (da 0.1uF ceramico) mettilo eventualmente  in parallelo

;)

Quote

La cosa strana è che a me funziona benissimo senza filtro RC e,se lo aggiungo,carica bene lo stesso...

Il filtro RC serve (ma non sempre) per i 1284P, i 644P non necessitano di esso.

tonid

Ah,ricordavo che con l'MCP c'erano dei problemi anche con il 644 8)

leo72


Ah,ricordavo che con l'MCP c'erano dei problemi anche con il 644 8)

L'unico che so che abbia avuto dei problemi con il 644P durante la programmazione via bootloader è stato Michele.
A lui il 644P funziona con filtro RC mentre il 1284P proprio non riesce a programmarlo.

Io ho sempre programmato il 644P senza filtro, mentre mi serve assolutamente il filtro con il 1284P.
Però preciso che io ho usato per ora solo l'Arduino UNO con l'Atmega328 staccato, quindi invece dell'MCP2200 ho usato l'Atmega8U2. Non so se questo fa la differenza. A parte il convertitore, anche in rete ho letto di problemi solo in relazione al 1284P.

tonid

Ricordavo bene allora che c'era un problema ma non ricordavo che lo avesse  Michele....Appena passa di quì vediamo se posso tornargli utile.
Il 1284 non me lo hanno dato disponibile quindi non posso fare prove anche con quello,dovrei vedere "sotto casa" se ne hanno ma la vedo dura.

Go Up