Go Down

Topic: uno no RX/TX is it dead? (Read 1 time) previous topic - next topic


I was using my uno as a battery monitor.

Uno + Serial Enabled 16x2 LCD + voltage divider R1=1400 1/4w R2 480 1/4

hooked it up using a bread board and it was great.
wile i was moving things around i nocked R2 loos this allowed more then 5v to go into analog pin1. Very shortly after nocking R2 loos my LCD stopped displaying values.

I figured I had simply destroyed A1 on my ATMEGA328p chip. Or posably the hole chip.

I tried to upload a pin 13 led blink sketch but got this error message: avrdude: stk500_recv(): programmer is not responding

so i figured the the  ATMEGA328p was dead. i was a little surprised as the doc suggests that individual ports in the IC could fail without total destruction of the chip. No bother, a new 328p with arduino boot loader installed is easily available and cheap.

Got the new chip check / rechecked the orientation. Then took a picture of the orientation. the removed the "dead 328p".
Installed the new chip. checked then rechecked the orientation then referred to the pic i took earlier to be shure the dot was facing the ICSP pins.

Plugged it into my laptop, opened arduino tryed to upload pin13 blink..... Nothing: avrdude: stk500_recv(): programmer is not responding

Maybe it dosent have the boot loader installed????

I used my arduino Nano 328 a 10uf cap some jumper leads and a lot of reading/forum time.
success I managed to burn the proper boot loader on to my uno/328p-pu

not to upload my pin13 blink sketch....... avrdude: stk500_recv(): programmer is not responding
this was the first time i noticed my Rx / Tx leds are not blinking (at all) not once....twice... but zero times.

so dose his mean my uno is no a 5v power supply???

It should be noted that when i press the reset button the led blinks several times the returns to full.
And i have tried holding the reset button till arduino say "Uploading"
And my Nano works fine

Thanks for any suggestions.


The RX and TX LEDs are run of the other chip.  The tiny little square one near the USB port.  It's either a mega16U2 or mega8U2 depending on which Uno you have.

When you plug the UNO in, does the green "ON" LED light up?


Yes the green led turns on.

16u2 by the way


Then the 5V power is okay.

Do you have access to another Arduino?  If you do you could try your 328 chip in it to see if it works, and try the other Arduino's 328 chip in your board.


You can bypass the 16u4 with a programmer.
In the file menu is an option to to upload the firmware via a programmer. You need a programmer ofcourse.

Go Up