Go Down

Topic: Info lcd Ks0108 (Read 10 times) previous topic - next topic

superzaffo

@Michele: Ho per le mani dei BC557, se puoi mandami una bozza di schema che lo provo.
grazie

Michele Menniti

io però non ho tra le mani il display :~ e il mio dubbio è che la foto che hai postato tu tempo fa non c'entra nulla con la disposizione che ho io. Ciò che ho notato e di cui sono ragionevolmente certo che che il pin 2 del mio BC857 (emettitore) andava dritto sul pin V- (o come si chiama, insomma quello che deve erogare -4V); di conseguenza il collettore va sui -4V e la base è l'ultima restante connessione. Prova a controllare il tuo PCB com'è, per verificarne le connessioni, che sono standard....
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

tonid

Ciao a tutti  :)
Oggi pomeriggio sono riuscito a disegnare,stampare ed incidere il pcb.....ho saldato i componenti,collegato arduino e caricato lo scketch di esempio della libreria I2C e tutto funziona a meraviglia.
Non vedo le righe segnalate da superzaffo.
Per ora ho fatto solo una schedina per poter fare due test vista l'incognita delle righe che si verificavano e visto che avendo solo smd non potevo montare su breadbord per provare direttamente.
@Michele
sulla scheda ho messo un led collegato ad un pin libero del 23017 da utilizzare per fare due test di simulazione sulla retro illuminazione così da non dover usare pin del 328......abbiamo già l'I2C,2 pin liberi del port expander quindi ho pensato di usarne 1.
@sz
Per il transistor confermo quello detto da Michele se non ti è molto chiaro fatti sentire.

superzaffo

Ok.. mi fa molto piacere quello che dici.. Allora probabilmente il problema delle righe è dovuto all'alimentazione... a me su breadboard da quelle righe che hai visto sulla foto...
Si, non ho molto ben capito di quale foto si riferiva Michele  ]:D
Quindi tu hai montato il 7660 sul display o sul PCB ? Hai messo anche quindi il transistor per amplificare l' alimentazione negativa...
Mi giri il file eagle ?

tonid

Quote
Ok.. mi fa molto piacere quello che dici.. Allora probabilmente il problema delle righe è dovuto all'alimentazione... a me su breadboard da quelle righe che hai visto sulla foto...

Si,credo anche io possa dipendere dall'alimentazione
Quote
Quindi tu hai montato il 7660 sul display o sul PCB ? Hai messo anche quindi il transistor per amplificare l' alimentazione negativa...

Io ho messo tutto sul display compreso il transistor,sulla scheda ho messo solo trimmer ,23017 ed il famoso led oltre alle R e C che servivano.
Tu non riesci a saldare tutto ciò che serve per l'alimentazione negativa sul display?

Go Up