Pages: [1]   Go Down
Author Topic: TFT and LCD SD CARD SHIELD PROBLEM SOLVED  (Read 3661 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 1
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

There are several different shields that can be bought on the net. The shields that I bought from China had some errors.
I could not get the SD card to work. On the LCD module the connector was not working and the Touch Screen + TFT LCD + SD  (billgps2010@163.com, design by JQT, 5/6/2012) had the SCK and SI switched.

TFT LCD Mega Shield V1.2 with SD card connector is not working for SD card.
NOTE: The wiring or routing is wrong SCK and MOSI is switched on the Shield (red PCB).
The best approach is to solder and remove the resistors and the connector.

The setup is MEGA 1280 + TFT LCD Shield + 2.4" TFT Display with SD card slot.
NOTE: Remove the SD card connector & resistors on the display module (blue PCB).

SOLUTION:
Solder a new SD card connector to the SHIELD.

SD card pin     SHIELD (pin)
1 (CS, SS)        53
2 (DI)              51
5(SCK)            52
7(DO)             50

3,6 GND
4 3.3V

The SD Library works with both FAT16 & FAT32.
The UTFTtf Library works only with FAT16.

SUGGESTIONS:
Use some hot glue to fixate the potentiometer (blue brick on the red PCB) and the wires on the TFT Shield.


* TFT_LCD.jpg (615.17 KB, 3264x2448 - viewed 89 times.)

* TFT_shield.jpg (614.54 KB, 3264x2448 - viewed 85 times.)

* TFT_shield_end.jpg (495.31 KB, 1024x593 - viewed 64 times.)
« Last Edit: December 11, 2012, 06:17:07 am by marwinrobot » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Did you have any problems with the touch sensor on this setup?

I think the touch sensor is not working properly on mine. Checked all the pin assignments and they seem okay

Every time I touch the screen it responds, but reads the same value every time regardless of where I touch the screen smiley-sad
« Last Edit: December 21, 2012, 03:26:55 am by jdmgt4 » Logged

Offline Offline
Newbie
*
Karma: 1
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The touch screen works with this setup. I have tested it. The only problem was the SD card interface.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello marwinrobot,

Nice report smiley-wink

My setup is Mega 2560 + TFT LCD Shield (the same V1.2) + 3.2" TFT Display with SD card slot, and it seems to have the same SD problem.
I suppose the solution for my 2560 is exactly the same...

Few questions...
Do do made the connections directly without any resistors?
Its really necessary remove the sd card slot and resistors from the LCD module? Since it are not in use, don't think it made any difference in the modification of the shield. What do you think?

Regards,
Pedro Lopes
PORTUGAL
Logged

Offline Offline
Newbie
*
Karma: 1
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I could not determine where the resistors were connected. Due to lack of time and interest I decided to remove everything. The resistors are protecting the SD card from over-voltage but usually they are 5V resistant.
If you are sure you wire to the correct pin on the SD connector, just leave the resistors mounted. However, I believe it is easier and more reliable to solder directly to a pin rather to a SMD surface.
Conclusion: either way is good.

Logged

Pages: [1]   Go Up
Jump to: