Pages: [1]   Go Down
Author Topic: problemi su ingressi analogici  (Read 432 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 54
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Salve a tutti. Ho un problema sugli ingressi analogici. In pratica sull'ingresso A1 ho il sensore di temperatura LM35DZ e sull'ingresso A2 il sensore di luce ambientale TEMT6000 (arduino ethernet). Quando li uso singolarmente non ci sono problemi. Leggo i valori ovviamente con analogRead. Poi ho creato un ciclo per leggere prima uno e poi l'altro. In questo caso quando avvicino una fonte luminosa al sensore di luce mi da un riscontro, ma nello stesso tempo mi comincia a variare ad intermittenza anche il sensore di temperatura e mi da dei valori assurdi tipo 44°C poi 17°C. Appena allontano la fonte luminosa dal sensore di luce la temperatura ritorna a funzionare correttamente. L'alimentazione di entrambi i sensori la prendo da arduino (5V) e anche la massa (GND). Sarà che non si possono collegare due ingressi analogici?

Aspetto vostri riscontri....
Grazie!
Logged

Marche
Offline Offline
Edison Member
*
Karma: 34
Posts: 2276
azioni semplici per risultati complessi
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Posta lo sketch che stai usando, senza è impossibile darti una mano
Logged

BZ (I)
Online Online
Brattain Member
*****
Karma: 270
Posts: 21863
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Alzo la quota: Sketch e schema come collegato sensori.

Ciao Uwe
Logged

Marche
Offline Offline
Edison Member
*
Karma: 34
Posts: 2276
azioni semplici per risultati complessi
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Uwe, la palla l'hai messa sull'albero di natale che chiedi di vedere lo schema?  smiley-wink
Logged

Pages: [1]   Go Up
Jump to: