Go Down

Topic: avrdude: stk500_getsync(): not in sync: resp=0x30 (Read 11 times) previous topic - next topic

robtillaart

So you have 3 Arduino's and 2 PC's
All the Arduino's work with PC1 but only one does work with PC2
Correct?


- try another cable
- try another USB port of your PC if possible
- reinstall the drivers (remove COMports from device manager)
Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

lost_and_confused

I have 4 Arduinos, and 2 pcs.

One of the Arduino may be faulty.

One is working and can be programmed.  As this is my alarm clock, it is now only done from my laptop.

The other two just won't flash from either.
One of those has been tried on a third pc and also fails.

The "faulty" one works in that I can upload the BLINK sketch and it works.
Other sketches upload but as some of the I/O lines are suspect, may not work.
Suffice to say the LED stops blinking when the new sketch is uploaded.  Then starts blinking when the BLINK sketch is uploaded.
Also there are no errors.

The two new cards give this "not in sync" error.

One is a freetronics one and is a genuine Arduino uno.

miker

Add me to the ever growing list of "not in sync" errors.  I'm using an Arduino UNO R3 / ZUMO Shield combo.
Had been working for a couple of hours then all of a sudden I started getting the subject error.
It started as an intermittent failure and is now solid.  I've tried all the tips suggested in this post as
well as others in this forum.  None work.  I've even update Arduino 1.0.1 to 1.0.3 and updated the USB drivers,
all to no avail....   ?????

oric_dan

There seems to be so many 1000s of people having the same problem, I would think
the Arduino development team might look into this, and either find a way for better
software driver installation, or else come up with a more bulletproof uploader program.
Maybe one that has some option settings.

Also, I think the problems have become worse with the newer R3 boards, ie, new
drivers, larger upload packets, and faster transfer baudrates.

One thing to try is see if the driver for the board is installed properly .... go to
Control Panel > System > Hardware > Device Manager, and see if the board shows
up in the Ports section when you plug and unplug the board.


westfw

Quote
There seems to be so many 1000s of people having the same problem

It's not "the same problem."  It's a generic error message that gets reported for LOTS OF DIFFERENT PROBLEMS.

I'm pretty sure that the R3 boards have the same bootloader and speeds as the previous Unos.

To the person with the Zumo shield - does it start working if you disconnect the shield?

As the nominal "owner" of Optiboot, I'd be willing to expend some effort to debug some of these mysterious failures (especially the ones that went intermittent to solid broken), but doing so over the net seems hopeless.  I'd need to have your physical board in my possession, and since I'm not a "vendor" I can't offer a replacement board or anything while I work on it.  I'd be willing to mail it back if I get it working, though.
So if you're willing to mail me your "dead" arduino for debugging, or if you're local to the SF Bay Area and have one of these consistently failing boards, PM me for contact info...

Go Up