Pages: [1]   Go Down
Author Topic: TMP36 Brownout possibley killed it  (Read 1145 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 25
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have a simple temperature / light monitor that worked quite well on one arduino, so i added a breadboard design and an RF transmitter and receiver so one ATmega328 was talking to another wirelessly.

I got this working reasonably well  for a little while until I decided to try some batteries instead of a 5V supply.

I used 4 AA batteries (6V average) but used a 3.3V regulator to tie the voltage to a nice stable one. This worked fine for a couple of days until I notice that my Cosm feed had nothing in it one morning (this morning). So I metered the battery pack and it was around 2.5V

A fresh set of batteries got the ardunio chip up and running again, but it started giving odd readings from the TMP36.

At first didnt think anything of it (on testing frozen to -25 the warm up curve is quite slow), but after it was running for an hour or so it was still reading between -11 and -7.

All code has remained the same so I know it is not that, I have tried a further ATMEGA and put this sketch on it and am now confused.

The reading of the TMP36 from a meter is 0.206mV and the reading of the ground line is 0.000V so is a good clean line. To me it looks like the voltage supplied was below the minimum voltage for it and has caused an issue with it. Unfortunately I do not have another to play with, so unable to check, but is this common?

If so what is the best way to monitor a battery voltage to turn off the supply to the TMP36 for the future?

I have thought of using a potential dividor to set the *fresh* battery voltage to just above 4.6V, tieing ARef to a 5V (not sure how to make as would need to be very low drop) supply and then monitoring this, but not sure if monitoring a battery voltage greater than the Vcc would be a good idea. Very confused here, but this is a 2nd point.

Any ideas are welcomed.

Jimmy

Edit, cosm feed is as below (will last around 6 days before new data pushes it out...
« Last Edit: December 11, 2012, 07:36:47 pm by manicmoddin » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 25
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Update...

Just having a little more of a play, the arduino (using LadyAda's example) is showing a readout of 0.38V and the meter is giving 384mV, so code is good, got to be TMP36 then.
Logged

Brunsbüttel, SH, F.Rep.GERM
Offline Offline
God Member
*****
Karma: 4
Posts: 596
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

usually the datasheets say a "absolute maximum voltage"...

what if u disonnect that TMP36 and connect it to 3V and measure its output then?
Logged

-Arne

Offline Offline
Newbie
*
Karma: 0
Posts: 25
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

When I took the TMP36 from the circuit and made a 3V battery pack (2x AA batteires) I got a reading of 0.665V which I get to around 21 degrees which is fine.

When I put it back in circuit, at around 4V I get much lower readings and at 3.3V I get lower still.

This really confuses me now.

I have ordered some more, but a little upset that I seem to have killed this one.

Tonight, I will try taking out the Microprocessor and all the other bits and try just on its own incase it is just very sensative, but I have not come accross this in the year or so I have been playing.

Cheers anyway...

Jimmy
Logged

United Kingdom
Offline Offline
Tesla Member
***
Karma: 224
Posts: 6619
Hofstadter's Law: It always takes longer than you expect, even when you take into account Hofstadter's Law.
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

It sounds to me that you have a low resistance between the mcu input pin and ground. Possibly due to a short circuit to an adjacent pin, or a faulty mcu.
Logged

Formal verification of safety-critical software, software development, and electronic design and prototyping. See http://www.eschertech.com. Please do not ask for unpaid help via PM, use the forum.

Brunsbüttel, SH, F.Rep.GERM
Offline Offline
God Member
*****
Karma: 4
Posts: 596
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

is 664mV a little low for 21°C?
it should b 500mV + 21°C * 10mV/°C, right?

what does ur analog pin say, if u connect 3V3 to it via a 100kR resistor?
u can measure the voltage over that 100kR resistor then... smiley

if DC42 is right, u can even say the resistance that disturbs the measurment...
Logged

-Arne

Offline Offline
Newbie
*
Karma: 0
Posts: 25
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Cheers for the replies.

Not had chance to have a look today, was a bad day at work and minecraft got the better of me, Amazing how something so simple can be so time consuming. Got in at 6, just realised the time and off to be lol

Will check this out tomorrow, but in the meen time, only things different are that the batteries went super flat (for the TMP36) and I put new ones, in, nothing else has changed.

I burned the sketch to another mcu and it made no difference, ut will try through a resistor as Riddick says.

Cheers once again.

Jimmy
Logged

Offline Offline
Newbie
*
Karma: 1
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hello
if you look at the datasheet of the tmp36, you can observe that it is very sensitive to electrostatic fields other device. and requires a electrical stability. So I think the bateries is not the best solution. to have less interference with other equipment, you can add a ceramic capacitor 0.1 uf in parallel and add a resistor of 750 owm on the analog pin tmp36

good luck!

Emmanuelle
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 25
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hello
if you look at the datasheet of the tmp36, you can observe that it is very sensitive to electrostatic fields other device. and requires a electrical stability. So I think the bateries is not the best solution. to have less interference with other equipment, you can add a ceramic capacitor 0.1 uf in parallel and add a resistor of 750 owm on the analog pin tmp36

good luck!

Emmanuelle

Think you hit the nail on the head there.

I did not have a 0.1uF ceramic, but instead a 10uF elecrolitic from another project. I think the fact that I have neglected the decoupling capacitors and this was causing a fluctuation (noticeable on the meter). One day I'll fix the scope.

After putting this across the main +- feed, this cured the readings...

Still just to work on a battery meeter now, but thats half the battle done now.

Many thanks for the help lesson learnt here is to use decoupling capacitors for everything. lol

Jimmy
Logged

Pages: [1]   Go Up
Jump to: