Go Down

Topic: "OUTPUT" was not declared in this scope (Read 2 times) previous topic - next topic


Just downloaded 1.03 and got the same basic problem in "Blink" and other basic sketches as I had in 1.02 and 1.01 (but not 0023) where "OUTPUT" seems not declared. There is a work around solution by adding some pointers to libraries but the install is straightforward and automatic and I get it on an Imac as well as on two Windows 7 laptops??? Anyone found a  solution or seeing the same problem. I tried an uninstall and reinstall on the windows PCs but same thing. I even tried renaming the library so it would only install the new library, same thing.

Can you provide full details of OS version (and avr-gcc version)?  Can you confirm that the blink example fails for you out of the box?

When you say "renaming the library so it would only install the new library" what exactly do you mean by "the library"?

Can you explain what these workarounds you mention are?

If there's a previous posting about the same problem can you provide a link to it (if so you should really have stayed in that topic,
not started a new one, it makes things much easier to deal with if all the conversation is in one place)
[ I won't respond to messages, use the forum please ]


Version on MAc is OSX 10.7.5  --

Sorry not conversant enough with Arduino to know where to find which avr-gcc version I am using.

Blink example is failing out of the box both on Imac and on Windows 7 PC.

The workarounds are the two lines included above.

By "Library" I just renamed on the iMac the documents Arduino folder "libraries"  and called it "old libraries" whilst doing a new install. Arduino seems to access the library "libraries" under Java and Resources as well as the one under documents and I suspected I have something screwy in the one under documents which is why I renamed it before an installation but then as the install created a new one which did the same as before with "Blink" I drew a blank there.

As far as the topic a full search under "OUTPUT" did not reveal any topics on that issue, I have only seen some references to a similar issue on googling the topic but not on these forum pages so I started a new topic.


I figured I had done something weird in my Arduino Sketch folder so deleted all versions of Arduino and renamed the Arduino Folder on the Windows PC as "Arduino-old" then reinstalled 1.03 and no more problem on the PC, so it was my personal sketch folder and something corrupt in the libraries folder I am sure. Still not quite sure how it happened but I do know there are others with this problem--just not surfacing on this forum so I did want to hang ny dirty washing out until I solved it. Now to figure it on the Imac folders.


Dec 16, 2012, 04:49 pm Last Edit: Dec 17, 2012, 11:48 am by AcmeUK Reason: 1

I am new to the Arduino, but not to programming.

I am trying to start using an Arduino clone. I have downloaded the IDE (V1.0.2) and trying the Blink sketch.

I get the same OUTPUT error message. If I look at the IDE, at the bottom in the 'debug area' there is a series of messages, the first is 'Blink.ino:10:21: error: Arduino.h: No such file or directory' which I think indicates the basic problem.

I have searched my arduino directory and I find that Arduino.h is in the arduino\hardware\arduino\cores\arduino directory.

So what is the problem?! From previous programming experience I would tend to look for a 'typo' in a link file or similar.

However it is a 'Bad Show' if new users are foiled at the first hurdle.

I do have a Alpha copy of the IDE V0021. The sketch runs fine in this, so it is not a OS problem. Searching the arduino directory of this version I find that there is no arduino.h file. Is this a clue? Did someone forget to change a path in a definitions file of the more recent versions?

Just for completeness I am running WinXP with all updates.

I Hope this helps.


Now 'sorted'.

I can confirm that putting the following at the top of the script fixes the issue:-

Code: [Select]
#include <WProgram.h>

I have tested this with the blink sketch with V1.0.3 and V1.0.3 of the IDE.

However I think it is a 'Poor Show' to release updates that are not fit for purpose, and do not seem to have undergone any basic regression testing! See http://en.wikipedia.org/wiki/Regression_testing


Go Up