Pages: [1]   Go Down
Author Topic: Problem with 5V pins...  (Read 298 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 94
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm having a problem with the 5V pins on both my Uno and Mega... I'm trying to signal a mosfet and no matter if I use a pin and set it to high or connect to the 5V output it won't work.

So, I tried different power adapters, usb, etc.... If I measure voltage at the pin it's a solid 5V. If I connect a wire to the pin and then measure the voltage at the other end it'll be lower, dropping in relation to the length of the wire. It's like the pins are putting voltage out but no current. I get the same results if I try the 3.3V pin.

Previously I was setting the pin from high to low to shut the mosfet gate, but I added a 10K pull-down because I was having a problem with the mosfet gate remaining open even after 5V was removed. Could this have damaged the board by pulling too much current?

I had no problems with this setup previously, then I packed the arduino's away for a few months and now just seems like the capacitors are dead or something, I don't know.



Logged

Massachusetts, USA
Offline Offline
Tesla Member
***
Karma: 180
Posts: 8108
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Did you remember to connect the Arduino ground to the MOSFET ground.
Logged

Send Bitcoin tips to: 1L3CTDoTgrXNA5WyF77uWqt4gUdye9mezN
Send Litecoin tips to : LVtpaq6JgJAZwvnVq3ftVeHafWkcpmuR1e

Offline Offline
Jr. Member
**
Karma: 0
Posts: 94
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

No. I'm powering all the devices, etc, (other than the arduino which is on a wall wart) through a PC PSU... I connected the ground pin on Arduino to the ground coming from PC PSU and what ya know, it works now lol.
Last time I powered the Arduino with the PC PSU through a barrel connector which explains why I had no problems! D'oh!


Thank you so much for the help!
Logged

Massachusetts, USA
Offline Offline
Tesla Member
***
Karma: 180
Posts: 8108
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thank you so much for the help!

No problem.  It's a common mistake which is why it was my first guess. smiley
Logged

Send Bitcoin tips to: 1L3CTDoTgrXNA5WyF77uWqt4gUdye9mezN
Send Litecoin tips to : LVtpaq6JgJAZwvnVq3ftVeHafWkcpmuR1e

Pages: [1]   Go Up
Jump to: