Go Down

Topic: stk500_getsync(): not in sync: resp=0x00 leonardo (Read 1 time) previous topic - next topic

Dec 14, 2012, 03:18 am Last Edit: Dec 15, 2012, 05:52 am by silverplasticbox Reason: 1
I put a sketch on my first leonardo and USB device not recognized popped up.  Thought I might need to re-flash the bootloader.  I have 2 leonardos, I've connected them several different ways, keep getting same error stk500_getsync(): not in sync: resp=0x00  Yay!  I've googled and googled. I can't find anyone trying to use 2 leonardos.  Not sure if that's the issue.  Need help.

bad board - good board

Dec 14, 2012, 03:29 am Last Edit: Dec 15, 2012, 05:55 am by silverplasticbox Reason: 1
Code: [Select]
C:\Documents and Settings\Ahhhhh\My Documents\Downloads\arduino-1.0.3-windows\arduino-1.0.3\hardware/tools/avr/bin/avrdude -CC:\Documents and Settings\Ahhhhh\My Documents\Downloads\arduino-1.0.3-windows\arduino-1.0.3\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega32u4 -cstk500v1 -P\\.\COM4 -b19200 -e -Ulock:w:0x3F:m -Uefuse:w:0xcb:m -Uhfuse:w:0xd8:m -Ulfuse:w:0xff:m

avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
        Copyright (c) 2007-2009 Joerg Wunsch

        System wide configuration file is "C:\Documents and Settings\Ahhhhh\My Documents\Downloads\arduino-1.0.3-windows\arduino-1.0.3\hardware/tools/avr/etc/avrdude.conf"

        Using Port                    : \\.\COM4
        Using Programmer              : stk500v1
        Overriding Baud Rate          : 19200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.

going to try

Got a new error.  YAY! 

Yikes!  Invalid device signature.
Double check connections and try again, or use -F to override this check.

That's further... right?

It would appear, that I'm at another dead end... back to google.

I'm stuck.  Anyone know the best/cheapest way to put a bootloader on a Leonardo?  As I've found that you can't just use another Leonardo, which I thought would have worked right out of the box... no, no it didn't.


Try this tutorial http://www.gammon.com.au/forum/?id=11635

Thanks codlink I'll try it today (20th), been busy.

Nope, went back to "stk500_getsync(): not in sync: resp=0x00" 

Sooo, what would be better to use to flash a bootloader? 

Go Up