Go Down

Topic: Problema sensore termico e servo motore (Read 921 times) previous topic - next topic

Canjul

Ciao ragazzi,sto lavorando ad un progetto per l'università ma sono incappato in uno strano problema,ho creato un circuito composto da un sensore termico (che va in input nel sensore analogico A0) e un servo motore attaccato al pin digitale pwm 9(in parallelo al servo c'è un condensatore da 100 mF).La mia intenzione era quella di far rilevare al sensore termico la temperatura, e farla indicare poi al servo, cioè ad ogni temperatura corrisponde un grado specifico di rotazione del servo.Il problema è questo,se il servo è staccato, il sensore funziona alla perfezione,segnando la temperatura esatta,invece appena attacco il servo,il sensore impazzisce,iniziando a fare sbalzi di temperatura assurdi,tipo da 20 gradi ne salta a 50! Per poi riscendere a 30!tutto questo ovviamente manda in tilt il servo che inizia ad avere dei veri e propri spasmi!Inoltre dopo questa anomalia,se utilizzo il sensore termico,esso inizia a indicarmi temperature prossime allo zero,per poi tornare al normale funzionamento dopo poco tempo.Vi chiedo dunque,cosa c'é che non va ???Aspetto il vostro aiuto!!!:)

cyberhs

Ma il servo è tipo quelli usati per modellismo?

Se è così, ha tre fili (nero, rosso e giallo) e solo il giallo va collegato ad un pin di Arduino usando l'apposita libreria.

Gli altri due, invece, sono l'alimentazione che, a causa dello spunto del motore, è bene sia diversa da quella di Arduino.

La presenza del condensatore e l'uscita PWM suggerisce che tu abbia pensato di pilotare il servo con l'uscita PWM, come se si trattasse di un normale motorino.

uwefed


Ma il servo è tipo quelli usati per modellismo?

Se è così, ha tre fili (nero, rosso e giallo) e solo il giallo va collegato ad un pin di Arduino usando l'apposita libreria.

Gli altri due, invece, sono l'alimentazione che, a causa dello spunto del motore, è bene sia diversa da quella di Arduino.

La presenza del condensatore e l'uscita PWM suggerisce che tu abbia pensato di pilotare il servo con l'uscita PWM, come se si trattasse di un normale motorino.


Oltre al filo dei dati deve essere collegato anche la massa (polo negativo) del alimentazione del Servo con la massa del Arduino.

Il Servo va pilotato con l'aposita libreria e il condensatore disturba il segnale.
Toglilo.

Ciao Uwe

Canjul

Ragazzi grazie dei vostri consigli,ora provo a rimuovere il condensatore come suggerito,nel frattempo vi mostro il circuito com'è fatto in modo che possiate mostrarmi ulteriori anomalie!Il mio servo comunque è dotato di un cavo bianco,non giallo,ed è quello che viene fornito con l'arduino starter kit. Inoltre l'ho collegato al pin 9 in modo da poterlo controllare dicendogli a che angolazione spostarsi all'occorrenza di una determinata temperatura.

BrainBooster

se stai facendo le prove collegato alla porta usb, potresti provare a spostare l'alimentazione del servo dal 5v a vin e vedere come reagisce il sistema.
Diversamente devi alimentare il servo a parte (sempre collegando il gnd a quello di arduino).
Senza sapere altro è difficile aiutarti...

Go Up