Go Down

Topic: [RISOLTO] Problema collegamento LCD con cavo ATA (Read 725 times) previous topic - next topic

jas1989

Dec 17, 2012, 08:27 pm Last Edit: Dec 18, 2012, 06:48 pm by jas1989 Reason: 1
Ciao a tutti,
nell'ultimo dei miei progetti ho avuto la male augurata idea di voler collegare un display LCD con la mia breadboard mediante un cavo.
A questo proposito mi sono procurato (cannibalizzando un pc) uno di questi vecchi connettori ATA, http://it.wikipedia.org/wiki/Advanced_Technology_Attachment e mi sono messo ad armeggiare per farlo funzionare.
Ovviamente (purtroppo), non ci sono riuscito...

- uso Arduino Uno
- LCD da segni di vita, si accende lasciando tutto lo schermo nero (ho provato a modificare il contrasto ma non è servito)
- LCD collegato direttamente sulla breadboard funziona
- il cavo ha 34 pin
- i fili del cavo sono tutti integri (ho provato col tester su tutti i pin che utilizzo)

Ora probabilmente la soluzione del mio dilemma è banale,ma rivolgo a voi la questione chiedendovi se avevate idee che giustifichino il fatto che non funzioni.

Grazie a todoss

Ps: quando sono a casa vi mando un pò di foto che magari rendono meglio il problema

brunello22

Si. Forse e' il caso di postare qualche foto
"C' è chi legge Guerra & Pace e non ci capisce un tubo vuoto; c'è chi legge l'etichetta delle patatine fritte e ci trova la spiegazione del mondo"

jas1989

Risolto mentre preparavo le foto da mettere!
Ovviamente il problema era piu semplice di quanto si potesse pensare! Uno dei piedini http://www.settorezero.com/wordpress/contents/2012/04/TILE_1x6header_150.jpg che inserivo nel cavo non faceva contatto..
Ho risolto sostituendolo!
Grazie comunque per l'interesse!

Go Up