Go Down

Topic: Arduino + MD03 : problemi di software (Read 355 times) previous topic - next topic

robyttt

Ciao a tutti,son nuovo sia del forum sia per quanto riguarda "Arduino". Di elettricità, diciamo, me la cavo,in informatica e cosette associate,beh,sono una frana.Sto,quasi finita la costruzione di un modello dinamico di funivia: la Treb/Stall,visibile anche su youtube (stesso nome) . Per azionare l'impianto,oltre che in "Manuale" tramite un alimentatore PWM fai da te(me),ho inserito anche un sistema in automatico tramite appunto la scheda Arduinouno,il software,creato da un amico"virtuale"  (lui è di Brescia,io sono in provincia di Trieste) e speditomi via mail,non ha soddisfatto le mie aspettative,tramite telefono non si arrivava a configurare (decelerare)  l'impianto (la fune) nei pressi dei piloni/sostegni o tralicci e delle stazioni d'arrivo, risultato : un paio di crash! (le cabine pesano 1.1kg l'una)  movimentate da un motore elettrico 12V  10A  +/- ( in partenza : Tracciato in salita) .Ho illustrato una panoramica.
Adesso chiedo a voi: Quando carico Arduino con il software ,accedo al monitor seriale e al posto di veder i parametri di configurazione: velocità minima,massima,rampa accel.,decel,lunghezza impianto,impulsi  encoder,mi vengono fuori tipo geroglifici ,sempre diversi; Cosa potrei aver combinato? ( 1a)       Per dialogare con Arduino ho installato putty, qui la schermata riesco a vederla,ma non posso correggerla,mi lascia solo scrivere (aggiungere), Cosa ho combinato? (2a)  L'impianto è un va e vieni (come una funivia vera) Parte piano (esce dalla zona fosse (dove ci ci "imbarca") ) aumenta di velocità,velocità massima,diminuisce la velocità,entra nella zona fosse (sbarco). Arduino vede l'arrivo cabina tramite sensore ottico,e ferma l'impianto,  inverte la marcia ,pronta per la partenza successiva.Intanto vorrei sapere se far un programma per quanto ho descritto sia problematico,(ricordo però che sono una frana). Infine (per ora) per resettare Arduinouno, vicino la morsettiera di potenza c'è anche un contatto/morsetto Reset:   collegandolo a massa si ottiene il reset?  Bene,ringrazio tutti coloro (e non) potranno aiutarmi in questa Avventura][/img]

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy