Go Down

Topic: Computer freezes completely after a few uploads (Read 3944 times) previous topic - next topic


Dec 20, 2012, 07:36 pm Last Edit: Dec 20, 2012, 07:41 pm by eralo Reason: 1
Hi everybody,

I'm using an arduino UNO on Win 7 64bit.

After a Reboot, everythings works fine, I can upload sketches and all. However, after a few uploads, my computer freezes completely (No mouse movement or anthings, only cutting the power helps) shortly after attempting an upload.
I have this issue on another machine (both slightly different Lenovo laptops) as well.

- I don't have the LVPrcSrv.exe service running
- Since I use the Arduino UNO there's probably no point in updating the FTDI Drivers
- I tried with IDE version 1.0.0 and 1.0.3

I haven't found much other troubleshooting info. Does anybody experience the same? Any Ideas what to try?

Thanks for any suggestions,



Windows reports some failure after the freeze? Can you check eventvwr.msc for critical errors? Can you check if there are minidumps created for every freeze? (PC properties, advanced, advanced, enable dumps)

I am guessing the problem is some electrical issue with your usb port.
My website: http://ried.cl


Thanks for the fast response

minidumps are enabled, I do have some in the windows folder, however none of them belong to these freezes (last one from may).

Windows doesn't report any failures after restart. The only critical error reported was:
"The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly."


Feb 20, 2013, 09:12 pm Last Edit: Feb 20, 2013, 09:21 pm by msdd Reason: 1

I can confirm this issue!
exactly the same as described above.

I use a Lenovo x201 with an i7 and indows 7x64 as well...

lets hope someone can find a solution...

It just happened again, although this time i did not even upload anything...
The USB connection with the UNO was established and the sketch editor was open.. and then everything froze....

Please someone help, this is so annoying it kept me from playing with the Arduino for a whole year.....

Coding Badly

Does Ctrl + Alt + Del bring up the task window?



i work as an systems engenieer, so I tried everything I know:

- no keystroke works
- not even num-lock or caps-lock
- no mouse movement possible
- no BSOD
- no dump files
- no eventlog entries

ist just like someone pulled the plug, but the screen remains on...

I see no point where to start with that mess...

please help...

Coding Badly

The kernel driver used for the Uno is provided by Microsoft.  The driver is ancient (meaning it has been well exercised by millions of people).  The kernel driver is very very unlikely to be the problem.

All of the software provided by Arduino runs in user mode.  It is impossible for a user mode application to lock-up Windows in the way you've described.

My suspicion is one of the Lenovo utilities or kernel drivers.  The last time we had something similar happen the Lenovo "boot optimizer" went haywire rendering the laptop useless.  A boot to safe-mode then removing it solved the problem.


I know this sound crazy but have you tired running Task Manager or Resource Monitor before you tried running the IDE?
Some times with Task Manager-> applications, you can gain control with the <end task>.
I had a problem with things hanging, and I used the <End Task> to gain control. My problem had to do with my desktop memory.
One of the Geek Squad pulled all my memory and cleaned the contacts on all of them, and put them back into my computer and that fixed my problem.
I really doubt that's your problem this time around, but the <End Task> might help.


Seeing as this is being reported on two different Lenovo laptops, I suspect a bad system-level driver common to Lenovo.  Perhaps try making sure that all the system-level drivers are up to date.  Pay particular attention to chipset/motherboard drivers.


Seeing as this is being reported on two different Lenovo laptops, I suspect a bad system-level driver common to Lenovo. 

Or there is a common application that Lenovo is installing which polls, communicates, and/or corrupts serial ports.

I think the idea to run task manager while uploading is probably one of the best ones. 
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Go Up