Go Down

Topic: Compilateur 0.22 --> 1.0.3 - Ne compile plus (Read 457 times) previous topic - next topic

Phoenix65

Dec 21, 2012, 01:04 pm Last Edit: Dec 21, 2012, 01:07 pm by Phoenix65 Reason: 1
Hello.

Je possède une version du compilateur d'arduino en version 0.22 et le code source de mon imprimante RepRap tourne parfaitement avec celui-ci.
J'ai testé avec la dernière version (1.0.3), il m'a converti mon fichier principal (.pde) car apparemment l'extension a changé entre temps, et mon programme ne compile plus, il a plein d'erreur.

Voici mon code source :
Soft.zip - 66.6 Kio

Il vient d'ici :
https://github.com/nrpatel/Klimentkip/tree/master/Tonokip_Firmware

Je n'ai touché qu'au fichier configuration.h

La partie pour la carte SD est inutile car j'ai pas de lecteur de carte, mais je n'ai pas les compétences pour savoir quels fichiers je peux supprimer.


Merci d'avance.


B@tto

Certaines expressions ont changé. Par exemple pour l'i2c ce n'est plus Wire.send() mais Wire.write(). Regarde où le compilateur bloque
Blog électronique : http://battomicro.wordpress.com/
Photographie : www.interactive-celebration.fr

Go Up