Pages: [1]   Go Down
Author Topic: Das Zeichen "~" ist in der IDE nicht eingebbar [gelöst]  (Read 1041 times)
0 Members and 1 Guest are viewing this topic.
Cologne
Offline Offline
God Member
*****
Karma: 11
Posts: 513
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,
heute habe ich zum erstenmal das Zeichen "~" für bitweise NOT eingeben müssen und festgestellt, dass das in der IDE nicht geht.
In anderen Programmen geht die Eingabe problemlos.
Ich nutze IDE 1.0 unter Kubuntu 12.04

Könnt ihr mal checken, ob ihr dieses Problem auch habt.
Gruß
Reinard
« Last Edit: December 23, 2012, 01:32:27 pm by erni-berni » Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 271
Posts: 21887
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ich mit IDE1.0.2 und WIN XP prof Sp3 funktioniert.
Grüße Uwe
Logged

Alfeld (Leine) / Germany
Offline Offline
Full Member
***
Karma: 9
Posts: 211
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Probier mal doppelt ~ zudrücken.

Hatte sowas mal vor einigen Jahren auf ner Sun Workstation...
Logged

Cologne
Offline Offline
God Member
*****
Karma: 11
Posts: 513
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Doppelt drücken hilft leider nicht.
Das Zeichen lässt sich übrigens mit "copy" (aus anderem Programm) und "paste" einfügen - hatte ich vergessen zu erwähnen.
Logged

Germany S-H
Offline Offline
Faraday Member
**
Karma: 172
Posts: 3252
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Könnt ihr mal checken, ob ihr dieses Problem auch habt.

Nö, kein Problem mit WIN7 und IDE 1.0.1

Und das Problem hat mit ziemlicher Sicherheit rein gar nichts mit Arduino oder der IDE zu tun, sondern mit dem Tastaturtreiber bzw. den Tastaturtreibereinstellungen des Betriebssystems.

Konkret mit der "Deadkeys"-Einstellung für die Behandlung von Akzent-Tasten.  Wenn Du die Tilde ~ als "Totes Zeichen"-Taste definiert hast, dann kommt das eigentliche Zeichen erst nachdem Du das nächste Zeichen danach angeschlagen hast.

Beispiel: El Niño
Da tippst Du erst die Tilde ~ und nichts passiert, dann tippst Du das n hinterher und es erscheint: ñ

Du kannst ja mal probieren die Tilde zu tippen und danach ein Leerzeichen: Kommt dann die Tilde alleine?

Falls Du nicht so oft "El Niño" und andere Begriffe mit Tilde über den Buchstaben schreiben musst, bietet es sich vielleicht an, den Tastaturtreiber des Betriebssystems auf "nodeadkeys" einzustellen. Dann kannst Du die Accent-Zeichen ganz für sich alleine eingeben.

Logged

Offline Offline
Edison Member
*
Karma: 21
Posts: 1419
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Mac OS 10.7, auch kein Problem ein ~ einzugeben.
Logged

0
Offline Offline
Faraday Member
**
Karma: 24
Posts: 3497
20 LEDs are enough
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Kannst Du das ~ Zeichen irgendwo anders eingeben? In einem normalen Texteditor?? Ich kann das jedenfalls unter Ubuntu und Kubuntu. Es gibt aber Tastatureinstellungen bei denen ich das auch nicht kann. Im Moment nehme ich "German - activate dead keys".
Logged

Check out my experiments http://blog.blinkenlight.net

Cologne
Offline Offline
God Member
*****
Karma: 11
Posts: 513
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hab gerade festgestellt, dass ich die Taste für "~", also [ALT Gr]+["+"]  zweimal betätigen muss, um das Zeichen zu erzeugen. Es geht auch mit Leetaste als zweiter Taste.
Offensichtlich wird das Zeichen als Zusatzzeichen, so wie im spanischen üblich, interpretiert. So kann man z.B. ñ erzeugen.
In der IDE geht es aber trotzdem nicht. Das betrifft allerdings nur das Editor Fenster. Unter Preferences z.B, kann ich eine Tilde eingeben.

Nachtrag: das gleiche scheint für alle "Akzent" Tasten in der IDE zu gelten, è, é, ê, ñ - geht alles nicht.
« Last Edit: December 23, 2012, 07:00:36 am by erni-berni » Logged

im Neckartal
Offline Offline
Jr. Member
**
Karma: 0
Posts: 60
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,
habs grade mal ausprobiert.
Auf meinem Desktoprechner mit Ubuntu 12.04 geht's, hier bekomme ich allerdings im normalen Editor (gedit) die Tilde aber auch direkt beim ersten Tastendruck.
Auf meinem Laptop mit Ubuntu 12.10 geht's nicht, hier habe ich im normalen Editor dieses "Doppelanschlag" verhalten für die Tilde.

Das muß wohl was mit dem eingestellten Tastaturtreiber zu tun haben:
Auf dem Desktop nennt er sich "Deutsch (ohne Akzenttasten)" und auf dem Laptop nur "Deutsch".

Grüßle Bernd
Logged

Theoretisch gibt es keinen Unterschied zwischen Theorie und Praxis ...

Cologne
Offline Offline
God Member
*****
Karma: 11
Posts: 513
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Danke Bernd,
das war die Lösung.

Ich habe jetzt beide Varianten des Tastaturtreibers installiert, umschaltbar mit einem Kurzbefehl.
Da ich nie Spanisch oder Französisch schreibe, werde ich Deutsch (ohne Akzenttasten) als Standard einrichten.
Bei Bedard kann ich ja dann schnell umschalten.

Gruß
Reinhard
Logged

Pages: [1]   Go Up
Jump to: