Pages: [1]   Go Down
Author Topic: avrdude: stk500v2_ReceiveMessage(): timeout error on MEGA ADK  (Read 953 times)
0 Members and 1 Guest are viewing this topic.
UK
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

My son bought me a Arduino Mega ADK for christmas.  We already had a Uno board R2 which was working fine.  I am using the blink LED example outputting to pin13 but when I upload to tje Maga ADK I get the following
avrdude: stk500v2_ReceiveMessage(): timeout
then it seems to upload successfully.  However I dont get this error with the Uno board. I have noticed on the Mega ADK a long pause before the TX and RX lights start to flash and I think it's this delay thats causing the error message.  I am using a Mac Pro with OSX version 10.8.2.  and Arduino version 1.0.3.  The correct board is selected and the setting is /dev/tty.usbmodem1d21 Programmer AVRISP mk11.  From a bit of googling around it appears others are having similar problems, but I can't seem to find a definitive answer.  Any ideas? 
Logged

Austin, TX
Offline Offline
Faraday Member
**
Karma: 63
Posts: 6049
Baldengineer
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

avrdude: stk500v2_ReceiveMessage(): timeout
then it seems to upload successfully. 
Do you have to click upload a second time or do you get the "error" message followed by the upload starting?
Logged

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

UK
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

avrdude: stk500v2_ReceiveMessage(): timeout
then it seems to upload successfully. 
Do you have to click upload a second time or do you get the "error" message followed by the upload starting?

No I don't need to hit upload a second time I get the error message followed by the upload.  Doesn't happen on the Uno though.   
Logged

Austin, TX
Offline Offline
Faraday Member
**
Karma: 63
Posts: 6049
Baldengineer
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

So then, what's the error?
Logged

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

UK
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

A big line in red had me worried. I thought possibly its a fault with the board. Especially when I found a few similar posts where this error message started appearing after a while. 
Logged

Pages: [1]   Go Up
Jump to: