Go Down

Topic: Arduino official wifi shield (Read 889 times) previous topic - next topic

frenk60it

Hello,

I recently bought the official arduino wifi shield but it does'nt seems to work...

When i try to connect to any network, with any security (open wep wpa) it always show the red error led.
Does this shield need to upgrade the firmware or there are something to do?
I tried the connection using the examples in the arduino ide.

Thank you very much for any suggestion

Francesco

ralfieroo

Hey Francesco,

   It can be rough getting the board working the first time.  I had very much luck following these steps outlined here:  http://www.sparkfun.com/tutorials/158  .

  Can you try that terminal program and let us know what type of responses you are getting?

Best of luck,
Dave

kamo


Hey Francesco,

   It can be rough getting the board working the first time.  I had very much luck following these steps outlined here:  http://www.sparkfun.com/tutorials/158  .

  Can you try that terminal program and let us know what type of responses you are getting?

Best of luck,
Dave



That is the Wifly shield, not the official ardiuno Wifi shield.

@OP:
After unboxing and plugging in, I never had any problems running the examples on the Wifi Shield. Would you mind posting your code?
Also, do note that the shield doesnt support WPA2, only WEP and WPA

kind regards,
kamo

frenk60it

Thanks, it works!!  :) :)

I don't have any router/hotspot since my laptop is connected to the internet via an internal HDSPA modem. What i did'nt understand was that the wifi must be connected to an 'ad hoc' network you should create on Windows (Win7 in my case), and then eventually you can enable the passthrouh to the Net.

Again thanks for your answers

cheers / Francesco

vanderbreye


Thanks, it works!!  :) :)

I don't have any router/hotspot since my laptop is connected to the internet via an internal HDSPA modem. What i did'nt understand was that the wifi must be connected to an 'ad hoc' network you should create on Windows (Win7 in my case), and then eventually you can enable the passthrouh to the Net.

Again thanks for your answers

cheers / Francesco


can you tell me what exactly was the error or what you have done??

i cant get the shield connecting to a WIN7 apn-wifi (WPA2) as well - but i'm able to scan for networks...

thx!

Go Up