Go Down

Topic: Problem running Gobetwino (Read 4669 times) previous topic - next topic

serbar

Guys i am starting to be somehow frustrated with this Leonardo board :(

Tried to run MegunoLink, can t get live data...

Tried to run Fetch, cant get live data...

Don t know if this deserves a new thread....

Thanks for your help.

PaulS

Quote
Don t know if this deserves a new thread....

Not yet. Lets see if we can't get GoBetwino working first. If so, then the change that needs to be made to GoBetwino probably needs to be made to the other classes you are having issues with.

You can then create new topics for each of them.

MikMo

#17
Dec 27, 2012, 09:30 pm Last Edit: Dec 27, 2012, 09:32 pm by MikMo Reason: 1
i will try to put the dtr enable in gobetwino, just give me a tiny little time  :)


PaulS

MikMo sent me a link to the new version of GoBetwino to test. It works with the Mega, the Duemilanove, AND the Leonardo. I'm sure he'll be making it available for all, soon.

MikMo

Ok so it was the DTR that should be enabled.

Thanks for testing Paul  :)

I will repackage GoBetwino ASAP.

There is also a little bug that was discovered recently that i will fix.


PaulS

Quote
There is also a little bug that was discovered recently that i will fix.

While you're at it...

It would be nice to change the serial port, and have that close the existing port, if opened, and open the new one, without having to restart GoBetwino.

MikMo


serbar

Quote
I'm sure he'll be making it available for all, soon.


Wonderfull :) Can t wait to try then.

Thanks.

serbar

And by the way, when fixed could you explain what was the problem(s)?

I would like to understand. And think other people would too.

Thanks again.

PaulS

The Leonardo uses a different USB to Serial converter chip from other Arduinos. This one appears to need the DtrEnable flag (Data Terminal Ready) set in order for communications to occur.

My code had it; why I can not remember. MikMo's (and most other) code does not, because it has not been necessary, until now.

MikMo added it to his code. His code is now able to talk to the Leonardo.

It's time, I think, for you to open the other threads we talked about, mentioning your inability to communicate with the Leonardo. Reference this thread, so the fix needed is obvious. I'm sure that quick turnaround will be possible on the other code will be made, too.

serbar


MikMo

There is an updated version here:

http://www.mikmo.dk/gobetwinodownload.html


serbar


serbar

Check.

I ran the examples for working with CPFIL and LGFIL commands with Leonardo and it works perfectly.

Thanks a lot guys.

Go to this thread that will guide you to gobetwino home page to download the recent version of gobetwino:

http://arduino.cc/forum/index.php/topic,139721.0.html

AngelinaT

#29
Apr 30, 2014, 03:31 pm Last Edit: Apr 30, 2014, 03:49 pm by AngelinaT Reason: 1
Guys excuse my english..I'm very new to arduino stuff..

I have exactly the same problem that you had with the Leonardo but in my case still doesn't work..Even the samples for the commands LOGFL..

To be more specific..

My project is very simple..An arduino leonardo, a light sensor and a relay..I want to save into a text file or a cvs file the lightning values that the sensor measures every 2 seconds (for example)..I've downloaded the gobetwino that you suggested here for the Leonardo.I've made a txt file, but the only thing i get is that the    "Serial port : COM8 opened at 9600 baud."

Here is my little code also in case that i've done something wrong..

#include <TinkerKit.h>
TKLightSensor sensor(I0);
TKRelay relay(O0);
int val =0;
//int countclosed=0;

void setup() {
 Serial.begin(9600);
 while (!Serial) {
   ; // wait for serial port to connect. Needed for Leonardo only
 }
}

void loop() {
 val = sensor.read();
 char buffer[12];
 Serial.print("#S|LOGLIGHT|[");
 Serial.print(itoa((val), buffer, 10));
 //Serial.print(";");
 Serial.println("]#");
 //Serial.println(val);
 delay(2000);

 
  if(val<=550)
  {  
     relay.on();
    //++countclosed;
    delay(2000);
  }
  else
  {
    relay.off();
    delay(2000);
   }
}

First i upload the sketch, then i open gobetwino(in the same port of course), but nothing happens..They seem not to communicate at all.
Thanks anyway, i'll be grateful if someone has any idea of what to do, or what i'm doing wrong..

Angelina.

Go Up