Go Down

Topic: Blown Caps in 0-30v 0-10a bench supply repair (Read 5251 times) previous topic - next topic

Suaveman

Dec 25, 2012, 06:13 am Last Edit: Dec 25, 2012, 06:31 am by Suaveman Reason: 1
While setting up my bench variable current/voltage power supply to put a equalization charge on a flooded lead acid, i stupidly forgot to turn the coarse current dial down before powering up the supply. As i turned the voltage up, i quickly knew something was up as the amps were ~3 at 14v. Before i could turn off the supply, or turn the current dial down, two electrolytic caps in the device blew, smoke came out of the device, and i immediately pulled the ac supply, turned the device off, and disconnected the lead acid battery.

I have done this before with the same battery/supply, but at currents below 1a. The purpose was to gas the battery, and attempt a bit of desulfation/overcharge on a heavily discharged battery. I think the high resistance of the battery was the issue here, as its not in great shape, but isn't dead either. I did not have a chance to check the wattage draw on my killawatt before the caps blew, but before, it was pulling ~20-30w when equalizing this lead acid at ~1a 15v.

I took the casing off, and saw two caps had blown open, one connected across the output terminals, (50v 470uf), and one on the regulation board above the multitap transformer (35v 470uf). No other visual damage was noticed, other than a short/broken trace next to the blown cap on the regulation board. I assume there was an ark there.

Is this something easily fixed by repairing the trace with a solder/wire joint, epoxying it to prevent future shorts, and replacing the caps?

Or did i just destroy my week old, semi-expensive bench supply beyond repair?

I know this isn't too specific as far as the details, but its a generic brand supply purchased off ebay.

Any ideas as to how this happened, or if i should attempt to replace the caps, and fix the broken trace? Any ways to test to see if that is the only damage done?

I really dont want to trash this supply, and i know its not returnable due to the sellers policy, but don't want to put myself at risk trying to fix it.

Any advice here is welcome, even if its what i don't want to hear (don't try and fix it yourself for saftey reasons).

Thanks-

Edit- heres the link to the supply in question-

http://www.ebay.com/itm/30V-10A-110V-Precision-Variable-DC-Power-Supply-w-Clip-Cable-Digital-Adjustable-/300833131292?pt=LH_DefaultDomain_0&hash=item460b0d4b1c

Can't find any kind of pdf schematic/datasheet, and all the info in the manual is pretty basic. Very hard to find info on this, makes me think i purchased a cheap POS knockoff, and a google search of the caps that blew turned up a few posts saying they were really terrible caps to begin with, JWCO brand. Might be ones from those bad batches made with stolen electrolyte formulas notorious for being of piss-poor quality, and having high failure rates. Badcap, the website has guides for replacing these as far as pc mobo/power supply blown caps, but this is a bit of a different situation.

Magician

Quote
Is this something easily fixed by repairing the trace with a solder/wire joint, epoxying it to prevent future shorts, and replacing the caps?

Unlikely easy to fix, probably caps were destroyed in consequence with diode bridge failure due over-current. Bad news,  would be a lot of damage parts, very difficult to fix - have to check up each components manually. No way for person w/o previous experience.


MarkT

You connected the battery backwards perhaps?  The output cap won't have seen 50V, so driving it backwards is the only likely way to
vaporize its innards quickly.  Might be other damage too if that's the case.

Or some other component failed upstream? 

Until you fix the obvious damage it'll be hard to tell.

You should always use a fuse inline with lead-acid batteries BTW, they can put out destructive currents if accidentally
shorted.

Find high-temperature electrolytics if you can to replace them, they will last a longer.
[ I won't respond to messages, use the forum please ]

dc42

It does sound as though you connected the battery backwards. If you are lucky, it will be just the capacitors that have failed. I suggest you replace them, solder a piece of wire to bridge the trace that vapourised, and carefully test it, allowing for the possibility that the voltage regulation may have failed and you may therefore get more volts out of it than you select.
Formal verification of safety-critical software, software development, and electronic design and prototyping. See http://www.eschertech.com. Please do not ask for unpaid help via PM, use the forum.

BenF


You connected the battery backwards perhaps?

This is making a lot more sense than assuming the load killed it. A bench supply will (should)  protect itself against overload.

There is a protection diode across the bench supply output that will short input to ground in case of reverse polarity. The idea here is to allow a fuse to blow on the supply side (your battery in this case). The battery however is not fused and so damage will occur. I would attemt a repair by replacing what's obviously broken (the open capacitors, the PCB trace) and also the reverse protection diode.

Chalk it up as 'experience', and put it on the shelf. Repair it later, maybe you can get a schematic for it. "Shotgunning" parts at it can be expensive and a waste of time. The 'inrush current' of a battery, which of course happens at the speed of light, can create a lot of smoke.

dhenry

Quote
I really dont want to trash this supply, and i know its not returnable due to the sellers policy, but don't want to put myself at risk trying to fix it.


Sounds like the only option is to hire someone to fix it for you, at a cost that potentially far exceeds that of a new unit.


A little googling found this address....of the manufacturer. Email them for a schematic.

http://www.chinarek.com/

Zapro

Yep, sounds like you connected the battery backwards. That is the only thing that could blow up the PSU.

Try to take some pictures of the boards that are affected. The circuitry in those kind of power supplies are dead simple, and repair should not pose any ptoblems, even requiring expensive parts. The only "advanced" part is the digital meters, but those won't be affected by your little stunt.

// Per.

mauried

Unless the PS is a switchmode type , and most arnt , it will simply be a transformer, rectifier bridge, and
some kind of linear regulator, using either transistors or Fets, most likley transistors.
Easy to fix.
The only expensive bit is the transformer , and that wont be damaged by incorrect volts on the output.

dhenry

Quote
Unless the PS is a switchmode type...


Trust me, this PS is a smps, with lots of electronics too.

Suaveman

#11
Dec 26, 2012, 06:11 am Last Edit: Dec 26, 2012, 07:17 am by Suaveman Reason: 1
Wow, lots of advice, thanks  :).

I can't be absolutely sure i had the polarity reversed, but i doubt that was the case, as the lead connectors, the clamps to connect to the battery, and the battery terminals are all heavily visibly labeled polairty wise. Though, i can't be sure. I'm pretty ocd about polarity when it comes to lead acids though, but once again not 100% sure.

Would the fact that its a starter battery with a bit of sulfation be of use?

The link to the manufacturer, i don't think is correct. The only supplys they have are dualoutput, with that middle ma/a current square switch. As well, theres no 3010D i could find on that site.

Heres some pics of the supply, and the failed caps-

http://imageshack.us/g/1/9934491/

And the icing on the cake, albeit a bit off topic- My sparkfun package i misplaced earlier in the day just got ran through a snowblower while i was taking these pics, containing a DEV10618 Power driver shield. :0 All that survived was the pcb. Mosfets, and all the other parts are scattered throughout the snow, or shredded. I seem to be destroying electronics far more frequently than usual this week. XD Gave pops a bit of a spook though, thought he hit a quail or something  :D

Glad it wasn't something more expensive. But at the same time i remembered my dad (snowblower operator) went to school to learn electronics theory, and worked on copier machines and slot machines for about 10 years. He also has a bit of expirence in working on crt tv repair. I'll have him take a look at the PS as well, and see what he thinks about it.

Probably just going to order a mastech from their site. I think i bought a cheap chinese made knockoff, and i'd rather just eat the loss and get something quality. But if anyone has any advice on possibly fixing the defective one i have, i'd still like to get it working if i can.

mauried

Id test the 2 output devices, they look like transistors, with a multimeter for collector - emitter for short circuit
and if good , replace all the dead electrolytic capacitors, and turn it on with no load.
If it works, a cheap fix, if not then its likley that the fault will be hard to find , unless you are really keen.

jackrae

From your photos it's definitely not a switched mode type supply so an effective repair is a distinct possibility.  One of the capacitors you destroyed is the one that is crappily connected across the output terminals so in all probability the cause of failure was reverse battery connection.  First attempt would be to replace the two capacitors and with no load connected see what happens to the output voltage.  If the regulating transistors have no diode protection against reverse voltage connection then they may also be destroyed, but you won't really know until you power up.  Yes you could strip them out for testing but a simply switch-on will tell you lots with minimal effort.

MarkT


Quote
Unless the PS is a switchmode type...


Trust me, this PS is a smps, with lots of electronics too.



Care to change your opinion having seen the photos?
[ I won't respond to messages, use the forum please ]

Go Up