Pages: [1]   Go Down
Author Topic: Aduino Uno + LCD  (Read 573 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo Community,

ich habe das Display (http://www.conrad.de/ce/de/product/183043/Alphanumerisches-LCD-Modul-Gleichmann-GE-C1602B-YYH-JTR-Zeichenformat-16-x-2-Zeichenhoehe-555-mm-Gelb-Gruen/SHOP_AREA_17651&promotionareaSearchDetail=005) versucht mit dem "Hello World" Beispiel zu testen. Leider habe ich gerade keinen Poti da. Geht es auch ohne?
Ich habe statt dem Poti mal einen 10k Widerstand genommen, aber das Display bleibt leer. Hat jemand eine Idee, LCDs OHNE Potis zu benutzen?

Gruß,
NewRegistrated
Logged

Offline Offline
Full Member
***
Karma: 1
Posts: 166
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hey,

ich habe das LCD Keypad Shield von SainSmart und darauf ist auch ein Poti. Das ist für die Helligkeitsregelung. Ich vermute deines wird für ähnliche Anwendung sein, du könntest also verschiedene Widerstandsgrößen ausprobieren... bei irgendeiner ist dann die Helligkeit so wie sie dir zusagt. Wenn das poti für die Beleuchtung ist.

Gruß,
Tobi
Logged

Nobody is perfect but - impossible is nothing

Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Danke, aber so eine Auswahl an Widerständen habe ich leider auch nicht.
Hab jetzt noch einen 100k Poti gefunden und in fast ganz runtergedreht. Jetzt sehe ich, obwohl ich die "Hello World" Beispieldatei raufgeladen habe, nur auf der 1. Zeile des Displays 16 Schwarze Kästen. Die 2. Zeile ist leer. Woran könnte das liegen?

Und das mit dem LCD Keypad Shield ist nicht schlecht, vielleicht bestelle ich mir auch eins, aber vorerst will ich mein Bestelltes Display benutzen, falls es mir noch gelingen sollte...

Gruß,
NewRegistrated
Logged

Germany S-H
Offline Offline
Faraday Member
**
Karma: 139
Posts: 2896
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ich habe statt dem Poti mal einen 10k Widerstand genommen, aber das Display bleibt leer. Hat jemand eine Idee, LCDs OHNE Potis zu benutzen?

Die Ersatzschaltung für ein Poti ist nicht ein, sondern ZWEI Widerstände.

Schalte zwei Widerstände zwischen GND und 5V in Reihe, die in der Summe ca. 10K ergeben, z.B. einen 3K und einen 7K Widerstand. Und in der Mitte zwischen den beiden Widerständen ist dann Dein "Poti-Abgriff" für die Kontrastspannung.

Genaue Werte mußt Du dann ausprobieren, wenn Du für die Kontrastspannung im Datenblatt keine genauen Vorgaben hast. Die Kontrastspannung teilt sich dann auf wie das Verhältnis der Widerstandswerte. Je nachdem wie herum Du die Widerstände verbindest, lassen sich mit 3K und 7K Kontrastspannungen von
5V*3/10= 1,5V
5V*7/10= 3,5V
Oder mit Widerständen von 2K und 8K von
5V*2/10= 1V
5*8/10= 4V
realisieren.

Mit Poti geht die Einstellung natürlich bequemer als mit ausprobieren verschiedener Widerstandswerte in einer Spannungsteilerschaltung.

nur auf der 1. Zeile des Displays 16 Schwarze Kästen. Die 2. Zeile ist leer. Woran könnte das liegen?

So sieht das leere Display nach dem Einschalten aus, bevor irgendwas darauf ausgegeben wird.
« Last Edit: December 27, 2012, 07:48:58 am by jurs » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Aber wie kann das sein, ich lasse doch den Text "Hello World" anzeigen, dann sollte es doch nicht mehr leer sein.
Kann es vielleicht daran liegen, dass der 100k Poti (ma sollte ja einen 10k Poti verwenden) den Strom zwischen GND und 5V zu stark abschwächt?
Oder kann es sein, dass ich einen Draht des Displays nur zu schlecht gelötet habe?
Logged

Germany S-H
Offline Offline
Faraday Member
**
Karma: 139
Posts: 2896
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Aber wie kann das sein, ich lasse doch den Text "Hello World" anzeigen, dann sollte es doch nicht mehr leer sein.

Falsche Verdrahtung.

Und zwar nicht des Kontrast-Pins, der Kontrast ist offenbar korrekt verdrahtet, wenn Du die Rechtecke in der ersten Zeile siehst. Aber die anderen Drähte...

Wobei Du im Prinzip das LCD Display fast verdrahten kannst, wie Du lustig bist, Du mußt nur die LCD-Library mit den richtigen Pins zur Initialisierung aufrufen.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hab die Drähte noch mal kontrolliert. Der Draht bei D6 ist einfach rausgesprungen... Jetzt sehe ich auf beiden Zeilen 16 Rechtecke -.-

Was könnte sonst noch eine Fehlerquelle sein?
Doch der zu große Widerstand zwischen GND und 5V? Der hat zwar mit dem Kontrast nichts zu tun, aber evtl. mit der Datenübertragung?

Edit:
Hab jetzt noch einmal am Vorwiderstand für den Kontrast des Displays was verändert. Jetzt geht es. Werde mir also mal ein paar 10k Potis bestellen, die kann man ja anscheinend öfters gebrauchen...
« Last Edit: December 28, 2012, 06:40:38 am by NewRegistrated » Logged

Pages: [1]   Go Up
Jump to: