Go Down

Topic: Arduino Networked Lamp Processing sketch error. (Read 6889 times) previous topic - next topic

PaulS

Quote
but now it can't load the HelveticaNeue-bold font...

Does the font that Processing uses REALLY matter? Have you placed the appropriate font file in the appropriate directory?

Forrest_Erickson2002

I was not able to figure out how to fix the font problem so I simply commented out the lines like this:

  //font = loadFont("HelveticaNeue-Bold-32.vlw");
  fill(255);
// textFont(font, 32);


Then the program ran but produced no results.
The URL from the book is not responding I think.
I changed the URL like this:
String feed = "http://blog.makezine.com/index.html";

I was then getting results .

Thanks for the help above with the java includes. I would never have overcome that problem.
Tyson: When you're scientifically literate, the world looks different to you.

thomm

Hi all, i am not very familiar English, sorry for my poor English.
I am now using processing 2.1 for this project and i've revised my code by including java with codes mentioned above:

import processing.serial.*;
import java.net.URL;
import java.net.URLConnection;
import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.util.StringTokenizer;

yet, when I tried to run this program, Processing stopped and show error message  "The package "java.io,BufferReader" does not exist. You might be missing a library."

I'm a totally newbie ,I don't know if it is suitable to ask here (this is the only forum I know)
Is there any suggestion where I can download the libraries and how to install it?

PaulS

The error message does not match with the snippet of code you posted. (Buffered != Buffer).

thomm

thanks! this error is caused by my typo... :smiley-sad-blue:

Go Up