Go Down

Topic: ARDUINO DUE DAC0 NON FUNZIONA!! (Read 2315 times) previous topic - next topic

cece99






Ma non avrai mica collegato direttamente un altoparlante da 8 ohm ad Arduino?


Se l'ha fatto quasi sicuramente ha distrutto il pin, però chi scrive una cosa simile ". A speaker is attached to ground, and DAC0." su un tutorial ufficiale di Arduino, oltre ad essere un incompetente, dovrebbe pagare di tasca sua i danni che il suo "consiglio" provoca.
Sarebbe il caso che un Admin intervenga quanto prima per correggere il tutorial.




Gli incompetenti in questo caso sono (leggete voi i nomi):
/*

Demonstrates the use of the Audio library for the Arduino Due

Hardware required :
*Arduino shield with a SD card on CS 4 (the Ethernet sheild will work)
*Speaker attched to ground and DAC0

Original by Massimo Banzi September 20, 2012
Modified by Scott Fitzgerald October 19, 2012

*/
in ogni caso, adesso come faccio?

Saranno incompetenti loro, ma lo sei in parte anche tu perchè dovevi controllare che le connessioni fossero giuste e che non rompessero arduino :).
Direi che al momento puoi usare DAC1 e fare a meno di usare DAC0


Io lo sono dato che ho appena iniziato  ;)

Ecco, questo è lo spirito giusto! Secondo me sarà impossibile avere qualsiasi tipo di risarcimento, quindi ti conviene usare l'altro pin CON I VARI ACCORGIMENI PER NON ROMPERLO ;)
Il Vero Programmatore non ha bisogno di manuali sull'assembler, sono
  sufficienti i data sheet dei microprocessori.

Fraa93



in seguito, collegando lo speaker all'altro pin (DAC1) si risentiva


Sarebbe il caso che non colleghi ulteriormente lo speaker al DAC1 se non vuoi bruciare pure questo pin.



Grazie dei consigli  :)

astrobeed


Saranno incompetenti loro, ma lo sei in parte anche tu perchè dovevi controllare che le connessioni fossero giuste e che non rompessero arduino :).


Ma che cavolo dici ?
Se uno è un principiante è normale che fa affidamento ai tutorial ufficiali, se sono sbagliati non ha certo colpa l'utente.

cece99



Saranno incompetenti loro, ma lo sei in parte anche tu perchè dovevi controllare che le connessioni fossero giuste e che non rompessero arduino :).


Ma che cavolo dici ?
Se uno è un principiante è normale che fa affidamento ai tutorial ufficiali, se sono sbagliati non ha certo colpa l'utente.


Non dico cavolate: quando ho preso arduino mica ìho collegato alla 220 e l'ho fatto esplodere, consultavo 2-3 tutorial per argomento per vedere se ci fossero errori e poi c'è scritto chiaramente che arduino due non è adatto a principianti..... mi sa che l'hai detta tu la cavolata
Il Vero Programmatore non ha bisogno di manuali sull'assembler, sono
  sufficienti i data sheet dei microprocessori.

astrobeed


Non dico cavolate:


Le dici eccome, se le istruzioni/tutorial ufficiali di un prodotto sono sbagliate la responsabilità non è certo dell'utente finale, è del produttore e del responsabile della documentazione, se poi il produttore ti rimborsa gli eventuali danni dipende dalle condizioni di vendita e da quanto è serio il produttore.
L'utente finale di un prodotto destinato ai non professionisti/esperti, si perché anche Arduino DUE è orientato verso questo target, non è certo tenuto a conoscere a fondo l'elettronica e/o la programmazione, uno si affida proprio ai tutorial ufficiali per iniziare e se questi contengono errori la colpa non può essere data all'utente perché non è esperto in materia.
Un conto è se uno collega 5V direttamente ad un pin della DUE, c'è scritto chiaramente che deve funzionare a 3.3V, fai un danno perché non hai letto almeno la documentazione di base, e un conto è se fai un danno perché un manuale d'uso/tutorial ufficiale del prodotto ti fa fare una operazione assolutamente errata, e ad alto rischio danno fisico, come collegare un grosso carico induttivo direttamente ad un pin di un micro.

Massimo Banzi

Il tutorial è sbagliato e verrà rimosso al più presto.

Fraa93 scrivi a support (at) arduino.cc spiegando il problema e ti verrà sostituito gratuitamente.
Mi spiace per questo inconveniente.

m

astrobeed


Il tutorial è sbagliato e verrà rimosso al più presto.
fraa93 scrivi a support (at) arduino.cc spiegando il problema e ti verrà sostituito gratuitamente.


+100 All'Arduino team   :smiley-mr-green:

Go Up