Go Down

Topic: arduino uno error (stk500_getsync(): not in sync: resp=0x00) (Read 3573 times) previous topic - next topic

xal3xhx

i get this error when i try to upload a program. can someone help me plz?
this is the code.

stk500_getsync(): not in sync: resp=0x00

Coding Badly


Do you have the correct board selected on the Tools menu?


Coding Badly


Have you ever successfully uploaded a program to the board?

xal3xhx

no i have not.
but it came with the blink program on it.

Coding Badly


Do you have the correct serial port selected on the Tools menu?

xal3xhx

yes.
there is only one.
for me it is com1.
i ma runing windows 7.

Coding Badly


When you connect the Uno to the computer, is the "device insertion" sound output?


Coding Badly


Have you followed the instructions here...
http://arduino.cc/en/Guide/windows

xal3xhx

no idid not do that right give me a min i will see if that works.


Munirul

I bought 4 $5 dccduino from ebay, two of them worked right out of the box, while other two refused to work with "not in sync resp=0x0" error. dccduino requires drivers from their chinese site, I ended up installing them on a WinXP VM. Anyway, was about to give up hope for other two clones, assumed hardware issue, as some has mentioned above. What worked for me is using one of the working dccduino as ISP (see Arduino as ISP tutorials), after burning bootloader and deploying blink sketch they started working. They would now work directly connecting via usb, no need for Arduino as ISP after first attempt.

ChilliTronix

The  dccduino uses a CH340 USB to serial converter. It takes different USB drivers.
Do not send technical questions as PM's they will be ignored.

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy