Go Down

Topic: None of the I/O pins work after burning a bootloader (Read 815 times) previous topic - next topic

szangvil

Dec 27, 2012, 12:31 pm Last Edit: Dec 27, 2012, 03:54 pm by szangvil Reason: 1
I used and Uno to burn a bootloader to my Nano from the IDE. It all went fine.

But now, I wrote a simple test program to see if the Nano works. It compiles and unloads without any issues. All the program does is set all the digital pins as OUTPUT and sets the to HIGH and LOW with a delay in between.
When I connect a LED or a small Piezo buzzer, I get nothing. I connected a scope to each pin and they are all "dead"... The same program works fine on another Nano I have (which I did not burn the bootloader myself).

Any ideas?

PeterH

I would guess that the bootloader isn't booting properly. Where did it come from? Does it do anything recognizable at boot-time that would enable you to confirm the bootloader is running, and is launching the main program? (My Nanos came preloaded with a bootloader that flashes the onboard LEDs as it starts up.)
I only provide help via the forum - please do not contact me for private consultancy.

szangvil

I used the bootloader from the Arduino IDE... Didn't try to invent anything... went by the book. Under Programmer I choose Arduino as ISP and under Board I selected Nano with 328 (the target board). Then I Click Burn Bootloader. Got no errors.

Disconnected everything and connected my newly burned Nano to the PC. Compiled and uploaded a program. Got no errors.

But I get no response from the IO pin...

James C4S

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com


PeterH

I wonder whether the problem is that the bootloader isn't launching the sketch, rather than that the I/O pins aren't working correctly. I don't know anything about the fuse settings but I recall that these are burned during the process of installing a bootloader - I wonder whether the problem is being caused by incorrect fuse settings, rather than a problem with the bootloader itself.
I only provide help via the forum - please do not contact me for private consultancy.

szangvil

I am sure it is not a hardware problem since the same Nano worked fine before I burned the bootloader (I burned the bootloader as an educational exercise).
As I said, I used the Arduino IDE to burn it and not any of the AVR tools that let you fiddle with all the settings.

PeterH

Yes, but as I understand it the IDE does set the fuses when you install a bootloader and may have used the wrong settings for your board. This is pure speculation on my part, I'm just trying to offer some avenues for you to explore.
I only provide help via the forum - please do not contact me for private consultancy.

szangvil

I see... I was under the assumption that using the IDE is the best way that should have worked...

PeterH

I would have assumed that too in your situation, but clearly something hasn't worked. I don't know what's causing your problem and I'm just speculating 'out loud' in the hope of coming up with some avenues to investigate that you haven't already considered.
I only provide help via the forum - please do not contact me for private consultancy.

szangvil

Thanks... I'll try using IDE version 1.0 instead of 1.0.1...

MarkT

Last time I tried burning a bootloader with Arduino 1.0 (or 1.0.3) it didn't work, so I backed off to version 0022 which
does work for me.  Slightly annoying as its the slower bootloader - there seem to be various posts about ArduinoISP issues
in 1.0 and later versions, so I suggest trying an earlier (or perhaps more recent) version.
[ I won't respond to messages, use the forum please ]

Go Up