Go Down

Topic: Compilation became incredibly slow (Read 6754 times) previous topic - next topic


Hi all,

I've been using Arduino happily for almost a year, but in the last two days something happened to the IDE: The "Compiling sketch..." phase takes forever, full minutes for the simplest sketch. Verbose output suggests it doesn't get stuck on any particular step - just goes extremely slow overall.

This also happens on the Energia (arduino IDE clone for the TI MSP430 Launchpad), so I guess there are some definitions gone astray in the system, for gcc or whatever both of these use. I've also installed the files for the "Zigduino" and uploaded a program for it before trouble started, but that's on a separate Arduino IDE in a different folder.

I'm using Windows 7, 64-bit. Any suggestions or solutions would be most welcome, except formatting the PC because that's not an option right now...

Thank you very much in advance,
My Adventures in the Making:


If you have bluetooth: http://arduino.cc/forum/index.php/topic,118440.0.html or disable the bt
My website: http://ried.cl


Thanks for trying, eried, but the BT in my laptop is disabled by default, and even after I stopped every windows service that looks even remotely related to BT, the compilation delay remains.

I've seen the BT issue is causing delays in uploading and serial communications, but to be clear, this is not the problem I'm experiencing. It's somewhere in the compilation/linking/building process.
My Adventures in the Making:


Well, I replaced the winavr toolkit so another option is to debug the problem yourself with Process Monitor. Filter arduino related events and check what is the one that takes a lot of time (maybe even the File summary can give you a hint)
My website: http://ried.cl


Are you running out of hard drive space on the drive where windows is installed or getting short on memory when the IDE is running that causes page swapping to HD?


Problem solved! It was ^%^$#%& ZoneAlarm!

I checked it based on a hunch and indeed, it somehow decided Arduino isn't trustworthy enough and bogged it down behind the curtains. Killing ZoneAlarm, or even setting the Arduino trust level there to the highest manually, brought speed back like magic.

Riva - thank you too, I forgot to mention that the slow compiling did not seem to affect anything else in the system, so it wasn't a resource problem.

Well, 'till the next mystery, folks! Have a great week!  :)
My Adventures in the Making:

I am having the same problem
the compilation process became very slow
can please help me to fix it?

Me too, high compilation speed with Windows-XP but on my laptop with Windows 7extremely slow speed!!!
Installed already latest Java, switched off McAfee etc however no improvements. What is the solution?


Me too, high compilation speed with Windows-XP but on my laptop with Windows 7extremely slow speed!!!
Installed already latest Java, switched off McAfee etc however no improvements. What is the solution?

Arduino IDE has Java built in to it's distribution, someone here suggested that if you have Java console installed then that may be used instead of the internal version. Have you tried un-installing Java, re-booting and then trying to compile a sketch using the IDE?


Same problem.
I set compiling to verbose and see lots of these lines
warning: this is the location of the previous definition

and these kinds
warning: "BIN" redefined
In file included from c:/documents and settings/jacques/my documents/arduino/arduino-1.0.4-windows/arduino-1.0.4/hardware/tools/avr/lib/gcc/../../avr/include/avr/iotn45.h:38,

and these kind of things, I guess referring to a problem within libraries etc. that came with Arduino.
C:\Documents and Settings\JACQUES\My Documents\Arduino\arduino-1.0.4-windows\arduino-1.0.4\hardware\tiny\cores\tiny\wiring_pulse.c:53: warning: cast to pointer from integer of different size

And even these kinds
c:/documents and settings/jacques/my documents/arduino/arduino-1.0.4-windows/arduino-1.0.4/hardware/tools/avr/lib/gcc/../../avr/include/avr/delay.h:36:2: warning: #warning "This file has been moved to <util/delay.h>."

Is that what is making my code so slow? I am using stock standard IDE 1.0.4.

Nick Gammon

Same problem.

Is that what is making my code so slow? I am using stock standard IDE 1.0.4.

Slow to compile or slow to execute? Is this an installation problem?
Please post technical questions on the forum, not by personal message. Thanks!

More info:


Execution is normal. When I click compile, it becomes slow. The same sketch that took a few seconds to compile now take several minutes. I did re-install Jave, unblocked Arduino in my Firewall etc, But since two weeks ago, prior to upgrading from 1.0.1 to 1.0.4 compiling takes much longer than usual.
Thank you


What kind of CPU and how much RAM? Can you watch task manager while compiling?
Avoid throwing electronics out as you or someone else might need them for parts or use.
Solid state rectifiers are the only REAL rectifiers.
Resistors for LEDS!


I did re-install Jave, unblocked Arduino in my Firewall etc

Have you tried uninstalling Java completely and trying? The Arduino IDE package includes it's own Java runtimes and I wonder if updating the full version of Java some how breaks these.


May 21, 2013, 02:53 am Last Edit: Jun 13, 2013, 01:57 am by terryking228 Reason: 1
I have been fighting this for months and finally found MY problem: ESET Smart Security  was apparently constantly checking USB ports and the Virtual com port etc.

My solution:

ESET Smart Security
- Realtime File system protection
 - Advanced Setup
   - Additonal Threatsense Parameters..
  • Advanced heuristics on executable files from removeable media

    IDE 1.04 and 1.05 BLINK went from 2 minutes to 15 seconds to Verify!  (FIRST Verify can take a long time.. 60 seconds or so...)

    *** UPDATE: Still having slowness problems; see following post..

Regards, Terry King terry@yourduino.com  - Check great prices, devices and Arduino-related boards at http://YourDuino.com
HOW-TO: http://ArduinoInfo.Info

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131