Go Down

Topic: Bees shield (2.12) + Seeeduino Mega 2560 (v3.0) wireless programming (Read 1 time) previous topic - next topic

syrinx

Hello,

I am successfully succeeded to us the XBee to do wireless programming with a Seeeduino Mega 1280. I have the message:

Quote
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer


But I can't do with Seeeduino Mega 2560. I used the same Bees shield with both Mega.

I've tried to change the bauds of the XBee to 115200. I've uploaded the blank code in the Mega before (DDRD=0x00). The Mega is plugged only to USB, XBee 2 and nothing else. I've changed for another bootlader.
I don't know what to do.

Is it a problem of compatibility with 2560?

Thanks.

syrinx

Probably due to the bootloader 'stk500boot_v2_mega2560'. But I didn't find one which was solving my problem.

draythomp

The bootloader for the 2560 is a continuing problem.  I have info about this on my blog here.

This problem is really annoying, but there are a couple of solutions for it now.  You DO have to reprogram the bootloader though to eliminate the problem.  If it's something as simple as having three exclamation points in a row in your source, you can fix that pretty easily.
Trying to keep my house under control http://www.desert-home.com/

syrinx

@ draythomp :

I spent also half a day to find the problem with !!!. Hrrrrr.

About Xbeee wireless programming, I didn't find any bootloader able don't do it. Did you?

draythomp

No, but you may be able to change the baud rate down to something lower and get it to work.  The file boards.txt has the baud rate the board should be loaded with.  You can set it to something lower in the file.  You could be outrunning the XBees, especially with long packets and such.  I'd take it down to something like 9600 and see if something changes.
Trying to keep my house under control http://www.desert-home.com/

syrinx

Hello,

I've tried to change boards.txt for the 2560 to 57600 bds, then to 9600 bds. I've changed also the bauds in each XBee chip. It's the same, I get also this message:

Code: [Select]
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer


Do you think that the speed inside the 'stk500boot_v2_mega2560' should be changed also?

draythomp

That I just don't know.  I've only experimented with the upload speed on the older Arduino boards and don't know much about the newer bootloaders.  However, you can check the source to see what they do about setting the port.  Also, you probably already know this, but you can set the sending XBee to one speed and the receiving XBee to another speed and it will work just fine as far as the XBees go. 

For example, you can set the sending XBee to 9600 and the receiving to 115K and the XBees will be fine with it.  I don't know what the bootloader will do with that.  But, it should get around the problem of the bootloader having a set speed that it works at that can't be changed.
Trying to keep my house under control http://www.desert-home.com/

syrinx

Other problem not related to the topic: when you compile a code with this mistake:

Code: [Select]
Serial.print(cumulAlert");

You saw the bad "

Then, the compilation is frozen! Another problem after the !!! issue.

syrinx

They say there that wireless programming is not working with 2560: http://www.dfrobot.com/forum/index.php?topic=225.msg857#msg857

With my Mega 1280, I can program, not with my 2560.

Go Up