Pages: [1]   Go Down
Author Topic: [Problème] Arduino Nano qui reset  (Read 359 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
God Member
*****
Karma: 12
Posts: 902
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour,

J'utilise une arduino nano sur un petit robot et j'ai un problème. La carte fait un reset et le programme uploadé dedans ne se lance pas, ça fait comme si ça commencait et après ça bug.

Savez-vous comment je peux résoudre le problème?

Le shéma est le suivant, sauf qu'à la place de l'atmega8 j'ai mis une arduino Nano:

http://letsmakerobots.com/files/userpics/u1533/Mr_General_ATmega8A_Wiiring_Instructions.jpg

Le pire c'est que ça fonctionne quand je connecte mon cable USB, mais pas quand je met une source externe.

?  smiley-mr-green
Logged

France
Offline Offline
Faraday Member
**
Karma: 55
Posts: 5347
Arduino Hacker
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour,

Tu as branché l'alim 4.8v sur Vin (alim avant régulation) ou +5v (alim âpres régulation) ?
Si tu l'as branché sur Vin ça ne pourras pas marcher (4.8v c'est déjà léger, alors avec la perte en tnsion du régulateur c'est foutu).
Logged

Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

Offline Offline
God Member
*****
Karma: 12
Posts: 902
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

J'ai testé avec une alim externe mais ça me fait le même problème.

Et oui je me suis mis sur Vin car quand les accus sont chargés je suis vers 6V, donc je voulais pas griller l'arduino.

Est-ce qu'il faut que je prévois une alim plus importante avec un régul 5V et que je me branche sur le Pin 5V de l'arduino?

Je vais voir si cet après midi j'ai le temps de tester avec une UNO...
Logged

France
Offline Offline
Faraday Member
**
Karma: 55
Posts: 5347
Arduino Hacker
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Et oui je me suis mis sur Vin car quand les accus sont chargés je suis vers 6V, donc je voulais pas griller l'arduino.
Effectivement 6v ça plaira pas à l'arduino sur la broche +5v ...

Est-ce qu'il faut que je prévois une alim plus importante avec un régul 5V et que je me branche sur le Pin 5V de l'arduino?
Si tu peut avoir une secondes batterie 9v relié sur Vin ce serait idéal.
La batterie 6v donnerai la puissance aux moteurs tandis que la batterie 9v (régulé en 5v par l'arduino) fournirai la tension pour l'électronique.
La solution d'une grosse batterie 9v + régulateur 5v externe (régulateur 7805 par exemple) peut s'envisager si t'as le matos.
Logged

Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

Offline Offline
God Member
*****
Karma: 12
Posts: 902
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Je viens de tester avec une UNO et une batterie Lipo 7.4V chargée à bloc ça fonctionne nikel!

Je vais refaire des tests avec la NANO après mangé

 smiley-mr-green
Logged

Pages: [1]   Go Up
Jump to: