Pages: [1]   Go Down
Author Topic: Motors no longer working  (Read 417 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 52
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,
I have 2 motors(1.5-3v) hooked up to 2 SN754410 motor drivers(1 motor on each SN754410). I attached both drivers on a breadboard and hooked them up so that they share the same power supply of 6v( 4 AA batteries) At first, they worked, but suddenly they stopped working. One motor does not work completely while the other motor only works for 1 or 2 seconds(supposed to work for 10 seconds). Is there something wrong with my power supply because my motors go really fast.And should I get some type of equipment like a voltmeter?
Logged

Manchester (England England)
Offline Offline
Brattain Member
*****
Karma: 603
Posts: 33385
Solder is electric glue
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
they share the same power supply of 6v( 4 AA batteries)
So have you checked the battery voltage? It could just be that you have drained them. Working for just a few seconds and then stopping sounds like it to me.
Logged

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 474
Posts: 18696
Lua rocks!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

And should I get some type of equipment like a voltmeter?

A multimeter is very handy. Lets you check voltage, current and resistance, and thus continuity.
Logged

Florida
Offline Offline
God Member
*****
Karma: 2
Posts: 559
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Also can we please see your code.

Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 52
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Oh, thanks guys,the battery was just drained. Also, if I want to use 3 motors, should I keep the 6v power supply(because the motors go really fast...its freaking me out a bit.)?
Logged

0
Online Online
Shannon Member
****
Karma: 200
Posts: 11707
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

That driver chip has darlington outputs so it will be reducing 6V down to 4 or so anyway, so 3V motors aren't going
to be massively overloaded (still its desirable not to overdrive motors, they get hotter and wear out faster).

Change those 4AA cells for 4 NiMH rechargeable AA's and that'll be about 5.2V instead of 6.0V, could help (with
the voltage and with the battery draining).
Logged

[ I won't respond to messages, use the forum please ]

Pages: [1]   Go Up
Jump to: