Go Down

Topic: [RISOLTO] Scheda Relay morta? (Read 1 time) previous topic - next topic

Michele Menniti

No, il comportamento è esatto, il fatto che un capo del diodo integrato nel fotoaccoppiatore sia collegato a VCC e l'orientamento del LED che indica l'attività del relé, ti fanno capire che il pilotaggio degli ingressi si fa con GND. Quindi:
1 - il 4° stadio è danneggiato, al 99% si tratta del fotoaccoppiatore, ma controlla bene le saldature, potrebbe non aver mai funzionato per una ragione del genere.
2 - ricollega la scheda ad Arduino, per il momento evita di usare l'alimentatore esterno, tanto dobbiamo solo verificare il pilotaggio dei tre relé buoni
3 - Collega +5V di Arduino a VCC della scheda relé e GND di Arduino a GND della scheda relé
4 - collega i tre ingressi In1÷In3 ad altrettanti pin di Arduino e via software imposta i pin come uscite con valore HIGH (in tal modo è tutto spento)
5 - imposta delay differenti per i tre stadi ed alla fine di ogni singolo delay porta la relativa uscita su LOW, quindi imposti un delay(1000) fisso, dopo il quale imposti tutti e tre i pin su HIGH; in questo modo ottieni che i relé si accendono in sequenza mentre si spengono tutti assieme.
Buon lavoro... ;)
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

leouz

#6
Jan 02, 2013, 08:31 pm Last Edit: Jan 02, 2013, 10:26 pm by leouz Reason: 1
Che figuraccia  :smiley-red:

ho sostituito il led e ora collecango il 4° si accende la luce ma non scatta.

Ho questo fotoaccoppiatore di riciclo dovrebbe andare bene giusto? (versione c)
http://www.cosmo-ic.com/object/products/k1010.pdf

di quello vecchio non riesco a trovare nulla di datasheet o simili
la dicitura che c'è scritto sopra è
B1219
817C
    G

attendo il via per prima di procedere  8)

EDIT: se no ho anche tanti bei NEC2501 http://html.alldatasheet.com/html-pdf/297601/NEC/PS2501-1/55/1/PS2501-1.html

EDIT 2: Preso da un raptus suicida l'ho sostituito con il primo fotoaccoppiatore!  e magia... FUNZIONA!!!! Garzie mille!!! Che gioia!

Michele Menniti

che via attendi? io ti ho detto di fare prima il test software, poi andremo a verificare il 4° stadio e cercheremo di capire cosa non va; se vuoi procedere diversamente il padrone sei tu e nessuno ti deve dare il via, no? :smiley-mr-green:
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

leouz

:smiley-sad-blue:
praticamente mi son fatto prendere dalla foga ed ho estirpato il problema... sostituendolo...  :smiley-sad-blue: :smiley-sad-blue:

leo72


:smiley-sad-blue:
praticamente mi son fatto prendere dalla foga ed ho estirpato il problema... sostituendolo...  :smiley-sad-blue: :smiley-sad-blue:

Controlla che le specifiche del nuovo fotoaccoppiatore siano compatibili con quelle del vecchio.

Go Up