Pages: [1]   Go Down
Author Topic: Strange Lines on Bitmap  (Read 746 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 43
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello everybody,

Currently working on my 3.2" TFT display (with SSD1289 controller) for my aquarium project.

Fortunately I got a second Mega 2560 for my paludarium tank the other day so I've been able to fiddle around on that and not have the LEDs on my tank flash every time I re-upload a program.

It has been a very steep learning curve for me but I'm starting to get the gist of it. The only software I've been able to fully compile and work is Henning Karlsens UTFT program and in that package the one that works the best that I've played around with and mostly figured out is the rotate bitmap example.

I managed to get my own pictures on it, as well as stop rotation, change size, and position of the picture. One thing I can't figure out is these annoying lines at the bottom right of each picture, assuming all the letters are their own little picture.


Logged

Global Moderator
Boston area, metrowest
Offline Offline
Brattain Member
*****
Karma: 538
Posts: 27114
Author of "Arduino for Teens". Available for Design & Build services. Now with Unlimited Eagle board sizes!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Looks like a software issue to me. Good luck solving it.

If you want others to look into it, you need to post or attach your code.
Logged

Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

Anaheim CA.
Offline Offline
Faraday Member
**
Karma: 47
Posts: 2892
...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have a similar issue with mine, a 3.2" Itead studios Glcd using the UTFT Lib (Thank You Henning) and I have a similar issue to yours I have a 20 cm 40 pin female to male adapter cable and occasionally when I move the cable I get a similar effect. Looking at that rats nest of wiring to the display I wonder about 2 things, first that display is not 5 V tolerant so unless you have the Mega's outputs fed to level shifters of some kind you might well have issues there. I don't think that is your issue though. Second I think more that you have an open/shorted connection somewhere between the Mega and the Glcd. I would recommend you Carefully without disturbing any of the wires do a continuity check for open connections. I say carefully because you might well fix it for a time by moving wiring. The next test I would think is a check for adjacent shorts. Pins that are bridged either with solder or a loose wire strand. It's hard to tell by looking at 40 red wires between a Mega and a display in a 30 cm wooden box though. Looking at that thing I can easily understand why it's in a box... It does look rather fragile and that is likely a big part of your problems. My display has a cable from the display to the Mega shield made for that display by Elec Freaks, The Sain Smart part is the same.. at least from the pictures but vastly overpriced.. and I would Highly recommend an interface shield made for the Mega and that Glcd.

Bob
Logged

--> WA7EMS <--
“The solution of every problem is another problem.” -Johann Wolfgang von Goethe
I do answer technical questions PM'd to me with whatever is in my clipboard

Offline Offline
Newbie
*
Karma: 2
Posts: 36
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have had similar issues. I like 40 wire ribbon cable and connectors, they are old, obsolete, and and cheap. Over a foot of cable and odd things start happening. I am assuming your calling a .c file in? I am also curious if you have tried the image in various sizes, the .c file can be modified and played with to get results. Nothing else works background(255,255,255) hahaha.
Logged

Anaheim CA.
Offline Offline
Faraday Member
**
Karma: 47
Posts: 2892
...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Not in 8 bits, .. No.

Bob
Logged

--> WA7EMS <--
“The solution of every problem is another problem.” -Johann Wolfgang von Goethe
I do answer technical questions PM'd to me with whatever is in my clipboard

Pages: [1]   Go Up
Jump to: