Go Down

Topic: Problema TX RX Modulo Bluetooth senza utilizzare i pin 0 e 1 (Read 595 times) previous topic - next topic

Davide-1991

Ciao a tutti e buona Domenica, ho un problema di comunicazione con un modulo bluetooth,
premetto che il modulo l'ho testato e funziona perfettamente sui pin 0 e 1 ma dovrei collegare il modulo senza andare ad utilizzare questi pin
sto utilizzando un'arduino mega, ho provato con la libreria SoftwareSerial e collegare il modulo sui pin 18 e 19, ma non riesco a comunicare con il modulo,
ci sarebbe qualcuno che sa dirmi in che modo fare e se è possibile?

Grazie ciao.

mancio

ma è una shield bluetooth? comunque metti un po di codice perchè cosi non è molto chiaro..provato a girare i pin? magari hai collegato RX al posto di TX e viceversa..

astrobeed


sto utilizzando un'arduino mega, ho provato con la libreria SoftwareSerial e collegare il modulo sui pin 18 e 19, ma non riesco a


La MEGA ha quattro porte seriali hardware, basta che colleghi il modulo ad una delle restanti tre e non devi usare la softwareserial ma le normali funzioni per la seriale con aggiunto il relativo numero.

http://arduino.cc/en/Tutorial/MultiSerialMega

Davide-1991

Ciao, astrobeed grazie mille per avermi risposto e grazie anche a manico...
Finalmente sono riuscito a far funzionare tutto correttamente,
non avevo compreso che bisognava utilizzare la normale funzione serial con aggiunto il numero,
mi era sfuggita questa cosa, anche perché utilizzo da pochi giorni la mega.

Grazie ancora e buona Domenica a tutti. :)

Go Up