Pages: [1]   Go Down
Author Topic: SM5100B send messages using cutecom  (Read 289 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I would like to describe you what I did until now and what problem I have. My project is to connect the SM5100B GSM with a Raspberry Pi which runs Raspbian (similar version to debian) and to send message in my mobile. I did the first, the connection with the Raspberry pi. I have the cutecom as hyperterminal<because is the only GUI terminal in Linux> which I opened it, I connected the device /dev/ttyAMA0 and finally I clicked in the 'open device button'.
I have the following message:
+SIND: 4

I would like to send a message in my mobile. I wrote the following Inputs and I had the following results:
at
OK
at+cmgf=1
OK
at+cmgs="my number"
OK
>Hello
>Hello

But when I type or press ctrl-z it doesnt do anything. I have a spanish keyboard. What is the problem here? Is the problem the keyboard? Is the Cutecom's problem? Do I have to write any code?
Logged

Global Moderator
UK
Offline Offline
Brattain Member
*****
Karma: 302
Posts: 26332
I don't think you connected the grounds, Dave.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Is there an Arduino question in there that I've missed?
Logged

"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.

Pages: [1]   Go Up
Jump to: