Pages: 1 [2]   Go Down
Author Topic: DC1307 configuration des voies  (Read 1409 times)
0 Members and 1 Guest are viewing this topic.
Ales
Offline Offline
Faraday Member
**
Karma: 39
Posts: 3749
Do or DIY
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Oula oué y'a des trucs vraiment bizarre ... La librairie je viens de l'explorer, aux lignes où sont notifiées les erreurs il n'y a absolument rien qui correspondent aux erreurs que tu trouves :s

Il faut reprendre à la base : re-télécharge l'IDE arduino et réinstalle le. Idem pour la lib : suit mon lien, recopie le dossier contenu dans le zip dans le dossier librairies du dossier arduino 1.0.3. Ensuite lance l'IDE, fichier, exemples, DS1307 et lance le seul exemple présent. Téleverse et vois s'il y a erreur ou pas cette fois.
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 43
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

C'est bon ça fonctionne,
c'est un bug du logiciel, à chaque nouvel essai je mettais la librairie dans le dossier "Arduino\arduino-1.0.3\libraries\DS1307Old" et installé la nouvelle librairie "DS1307" dans
"Arduino\arduino-1.0.3\libraries\".
Mais le logiciel malgré un reboot, va toujours chercher dans le dossier DS1307Old" et ce malgré #include <DS1307.h>
On voit le mauvais chemin dans le compilo, il va chercher une ancienne librairie.
Pour résoudre ça j'ai renommé le dossier "DS1307Old" en Old" et maintenant ça compile et fonctionne avec ma carte.
Seul bémol, il mets impossible de régler l'année 2013,( 2009, 2010,2011 ok).
Tout ça pour un bug de répertoire..

Logged

Débutant mais acharné!!

Ales
Offline Offline
Faraday Member
**
Karma: 39
Posts: 3749
Do or DIY
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Le truc c'est que les balises <> indique au compilateur de chercher lui-même le fichier. Donc il a dû tomber en premier sur le "old" qui contenait lui aussi un fichier DS1307.h.
Logged


Pages: 1 [2]   Go Up
Jump to: