Pages: [1]   Go Down
Author Topic: GPRS sleep mode DTR issue with Seeedstudio Shield  (Read 1468 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

I use GPRS shield from SeeedStudio with an arduino to post data to a website.
In order to put SIM900 into sleepmode , i tried the following as a part of a code:

Code:
void loop()
{

    //Code to upload data goes here

    //Enabling sleep mode in SIM900
    GPRS_Serial.println("AT+CSCLK=1"); //Enable Sleep mode, slowclock

    //D3 pin of Atmega used to drive DTR pin of SIM900
     pinMode(3, OUTPUT);

    //Pull DTR high to put it into sleep
    digitalWrite(3, HIGH);
    delay(100);

    delay(30000); // 30sec delay where the SIM will go to sleep

    digitalWrite(3, LOW); //wake up SIM900
    delay(100);// a minimim of 50msec is req

}

I had a wire going from DTR on J11 connector to Arduino D3 to toggle DTR pin. I am using Softserial interface.

After the execution a few times, i cannot get any reponse to any AT commands and looks like GPRS board is not responding to basic AT commands anymore. I dont get an OK from AT command anymore. I had the upload code working without putting SIM900 into sleep but not anymore since there is no response from GPRS shield for the AT commands.

Anyone tried to put SIM900 into sleep mode by using this approach ? I am concerned if i have damaged the serial interface of GPRS board. But I can see that the network registration is done from the flashing time of LEDs.

Any help is appreciated.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

anyone with ideas ?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 28
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,
have you solved the problem? I would bring the GPRS to sleep.

Thanks
Logged

Pages: [1]   Go Up
Jump to: