Go Down

Topic: stepper motor problem (Read 1 time) previous topic - next topic


I was using easydriver to control a stepper motor and a 9v battery. The motor specs are here in portuguese: http://www.robocore.net/modules.php?name=GR_LojaVirtual&prod=362   

it is refurbished.

9v  and 2A /phase

it was working fine but stopped. I started with theses values:

digitalWrite(x, HIGH);
delayMicroseconds(10); //A
digitalWrite(x, LOW);
delayMicroseconds(300);  // B

Then I tried increasing the delay, 20 microseconds for A and 3000 for B, and it worked for a while. But now the motor doesn't turn anymore. And I can turn it by hand with almost no effort, it wasn't like this before. There's almost no torque anymore.

What I'm doing wrong? Should I buy a new one?

Thanks in advance.


What are you using for the 9 volt source?
10us,  way to fast!!
No technical PMs.
The last thing you did is where you should start looking.


No technical PMs.
The last thing you did is where you should start looking.


Not many 9V batteries can supply 200mA, let alone 2A....

That stepper is rated at 2A per phase and 2 ohm winding resistance - therefore it needs 4V, not 9V.

I suspect the 9V is the voltage for bipolar operation (two windings in series).
[ I will NOT respond to personal messages, I WILL delete them, use the forum please ]


Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131