Go Down

Topic: AX-12+ Led blinks (Read 1 time) previous topic - next topic

feri_sharp

Hi.
I've an ax-12+, and when I turn it on, the led starts blinking.
I don't think it's a power supply problem, because, before it started blinking, when I turned it on by the power supply 9v(1A), led flashed once.
it started blink when I connected it by a FT232 Serial to usb converter module to PC and ran the roboplus firmware recovery, as it said when I click find, I should poweroff, power on the servo to find the servo. when I did this, it didn't find it, but the back led was turned on, after 5mins it started to blink. after that when I just power it on, it starts blink, and I wrote a code in bascom fot atmega32 and connected the ax-12 data pin to Rx pin of micro for read the error, but nothing happened.
I connected AX-12 to FT232 module in this manner: I connected the ax-12 data pin to rx and tx.

Sorry if it's hard to read.
And I appreciate any helps for that.
I don't have the USB2Dynamixel and CM-5  and any other productions for AX-12, I just have The servo and want it to run  without these products. but first i need to stop it from blinking.

Thanks

zoomkat

Quote
it started blink when I connected it by a FT232 Serial to usb converter module to PC and ran the roboplus firmware recovery


Why did you do that? Could that corrupt the chip in the servo?
Consider the daffodil. And while you're doing that, I'll be over here, looking through your stuff.   8)

feri_sharp

Hi,
i was tired of run the motor, 'cause before that I wanted to send a packet by atmega32 to just light the led, but nothing happened, I checked baud rate, cables, all was right, then I decided to do this, for a test, and then this happened, can u help me how to fix it?

zoomkat

Quote
can u help me how to fix it?


Google or the AX-12 are probably a place to start.
Consider the daffodil. And while you're doing that, I'll be over here, looking through your stuff.   8)

feri_sharp

I did all these things, I googled and read all topics about, I sent email to Korea(dynamixel), but they could'nt help me, 'cause I didn't use usb2dynamixel.

Go Up