Go Down

Topic: Amperometro usando un TA abbinato ad un HCPL-7520 (Read 690 times) previous topic - next topic

elvis

Ciao a tutti,
    sto cercando di realizzare un amperometro i cui dati vorrei fossero pubblicati si cosm.
Sto provando ad abbinare un trasformatore amperometrico (TA) ad un integrato HCPL-7520.
Purtroppo i dati che misuro con arduino sono completamente sballati. Qualcuno ha esperienza in merito?
Grazie

uwefed


elvis

In allegato c'è lo schema elettrico (che ho trovato da openenergymonitor) di come ho collegato il sensore ad Arduino.
Ho posizionato il TA in serie a vari utilizzatori diversi ed ho monitorato i consumi anche con una pinza amperometrica "tradizionale" ma, purtroppo, non riesco ad ottenere dei valori che abbiano un senso.

Ho tentato anche varie combinazioni di resistenza (R=22ohm di default) ma nada!

uwefed

Secondo il diagramma Figure 5 a pagina 9 di http://people.ece.cornell.edu/land/courses/ece4760/FinalProjects/s2010/jps89_cdq2_mam584/jps89_cdq2_mam584/HCPL-7520-300E-Avago-datasheet-7803.pdf
é la tensione proportionale alla diffeenza delle tensioni di entrata sommato a 2V.
Vout 2V+deltaVin*(Vref/0,512).
Secondo lo schema elettrico Vref é 5V e percui

Vout=2V+(Vin+-Vin-) * 9,765625

Nel Tuo caso é un segnale alternato a 50Hz. Devi cercare via Sw di fare la media quadrata (valore effettivo) o di trovare il valore massimo.

Se misuri la tensione Vout con un Multimetro nel range alternata i valori quadrano?

Ciao Uwe

elvis

Ciao UWE,
      scusa la mia latitanza ma non son riuscito a dedicare più un minuto ad arduino...
Appena riesco, cerco di seguire i tuoi consigli e vediamo cosa riesco a combinare.
Grazie ancora del tuo aiuto.
Elvis


Go Up